Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#7548 closed patch (fixed)

rearranging preference menu to fit on 800x600

Reported by: caseyho Owned by:
Milestone: 2.6.4 Component: pidgin (gtk)
Version: 2.5.2 Keywords: preferences size conversation font
Cc: pidgin@…, elreydetodo

Description

the current preference menu doesn't fit on an 800x600 screen. this was the first thing that popped up in an adhoc usability test i performed with a friend.

the conversation tab is at fault here. i looked for ways to shrink it- i then noticed that the "font" section and "formatting" section sound redundant. this is confusing.

after additional searching, the "font" section controls your local appearance, the "formatting" section controls what is sent out. simple enough.

to remedy this, i renamed the "smiley themes" tab to "theme" and moved "font" under there. the smileys section is also cleaned up a bit.

no functionality lost, and IMO the new arrangement makes mildy more sense. there may be a case for removing the "font" option altogether, as neither adium or digsby has such an option (design by committee? :))

Attachments (6)

themepreferences.diff.gz (2.1 KB) - added by caseyho 11 years ago.
mtn-sound.diff (3.9 KB) - added by mterry 10 years ago.
Rearrange Sound page
mtn-network.diff (3.0 KB) - added by mterry 10 years ago.
Network: move some fields to right
mtn-network-no-gnome-settings.diff (4.5 KB) - added by mterry 10 years ago.
Drop Proxy & Browser settings when in GNOME
mtn-theme.diff (15.2 KB) - added by mterry 10 years ago.
Rearranges font and smiley theme sections
small-prefs.tar.bz2 (402.9 KB) - added by mterry 10 years ago.
grand unified patch + screenshots

Download all attachments as: .zip

Change History (36)

Changed 11 years ago by caseyho

comment:1 Changed 11 years ago by deryni

I think it probably makes more sense to move the Font section to the Interface page as that is more appropriately what it is controlling. That being said I would be all for removing that preference (and the code it disables) entirely as I think it is a stupid, confusing preference and the feature that it allows is not one that is worth much.

comment:2 Changed 11 years ago by rekkanoryo

I personally have no preference on the existance of the outgoing formatting stuff, but I would like to remind everyone that if we remove that, we're going to have a ton of users crying because they can't set a default font anymore.

comment:3 Changed 11 years ago by caseyho

Hold back on removing preferences. The stats code I'm currently polishing will help resolve these issues with solid data. (Ask rlaager or me if you're wondering what it's about)

comment:4 Changed 11 years ago by deryni

In no way as I advocating removing the outgoing font preferences, I was suggesting we remove the use font from theme "preference" because I think it rather a confusing nightmare of a "feature".

comment:5 Changed 11 years ago by caseyho

Ironically, I think the fact that I understood rekkanoryo's comments incorrectly is a clear example of how confusing this all is.

comment:6 Changed 10 years ago by kstange

The reason that preference was added was to avoid the problem of having an unusable document font, largely GTK+'s fault on Windows, when users sent incoming formatting with font sizes of 2 or smaller. This is typical of AIM users because the default is to use a 12 point base font size for size 3 on the official AIM client, so users set their font to size 2, which is 10 points. Pidgin's base font size is 10 points, so it results in 8 point or smaller fonts for the Pidgin recipient of the messages.

If it can be made obvious how to change the document font setting via the GTK+ theme control plugin, then this preference could be removed, but that type of plugin functionality seems to be something people fail to find and have to ask about.

comment:7 Changed 10 years ago by deryni

The use_theme_font preference seems to be checked in exactly one place (gtkutils.c:pidgin_setup_html), when it is FALSE we forcibly set the font for these imhtml widgets to the font specified by custom_font and when it is TRUE the only other block of the if is "else if(purple_running_gnome())" wherein we grab the GNOME document font (assuming we can find gconftool-2) and forcibly set the imhtml to use that. In all other cases we do nothing. Which matches what I remembered of the reason for this preference being added which was people using Gnome and having never set a Document Font (because nothing uses it) and being annoyed that we were using this "strange" font they'd never seen before and couldn't figure out how to change.

Changed 10 years ago by mterry

Rearrange Sound page

comment:8 Changed 10 years ago by mterry

I added a patch for the Sound page to make it smaller. It moves the Sound Events section to the right of the other sections. It still fits 800 width, but now fits much better in smaller vertical resolutions.

I intend to have several other small patches to achieve the goal of this bug (make preference dialog fit small resolution). Should I keep adding patches/comments or file new bugs for each?

Changed 10 years ago by mterry

Network: move some fields to right

comment:9 Changed 10 years ago by mterry

mtn-network.diff moves the "Example: stunserver.org" text to the right of the server field and puts both Start Port and End Port on the same line.

Changed 10 years ago by mterry

Drop Proxy & Browser settings when in GNOME

comment:10 Changed 10 years ago by mterry

mtn-network-no-gnome-settings.diff is a more controversial change to the Network tab. It removes the Proxy & Browser buttons when in GNOME. The buttons only linked to the Proxy or Browser GNOME-wide preference dialogs.

I don't think they added much, and they made the page vertically-large. Imagine if every GNOME app had such buttons in their preferences. It would be unnecessary.

comment:11 Changed 10 years ago by deryni

I believe we put those buttons there because people who had previously used pidgin outside of GNOME (and just people in general) were unable to find the appropriate GNOME settings when the buttons were just missing. That's not an indication that I think they should stay just an explanation.

comment:12 Changed 10 years ago by deryni

Ticket #7500 has been marked as a duplicate of this ticket.

Changed 10 years ago by mterry

Rearranges font and smiley theme sections

comment:13 Changed 10 years ago by mterry

mtn-theme.diff replaces themepreferences.diff.gz. I took what it did and also moved the 'default formatting' section over.

I also moved the 'add' and 'remove' smiley theme button to the right of its scrollview. And made the 'default formatting' widget be a labelled widget under the 'font' section. It's label is 'Outgoing formatting:' to make it clearer what exactly it does (as different from the other font settings).

With all the above patches, the preferences dialog is ~710x530 pixels for me. Yay! We fit!

comment:14 Changed 10 years ago by mterry

I've filed a similar bug+patch for the account editor (bug #8663). That patch fixes the issue with SILC protocol being enormous.

As a reminder, all of the above patches are ready to go (with the exception of mtn-sound.diff, which I have to rework to address mailing list concerns about the two-column layout). I'd really appreciate a review or commit.

comment:15 Changed 10 years ago by mterry

Oh, god. I finally came back to this bug to help finish it off, and the preferences are even more enormous now. I may have more patches coming.

Changed 10 years ago by mterry

grand unified patch + screenshots

comment:16 Changed 10 years ago by mterry

Here is a grand unified patch. This obsoletes all the above patches and is against current git master (meaning it takes the new theme dropdowns into account).

Things this patch does:

  • Moves 'Font' section from 'Conversation' tab to new 'Font' tab
  • Moves 'Sound Events' section from 'Sounds' tab to new 'Sound Events' tab
  • Renames the tab 'Smiley Themes' to 'Theme' and 'Sounds' to 'Sound'
  • Moves 'Buddy List Theme' section from 'Interface' to the renamed 'Theme' tab, sharing the spotlight with the smiley themes.
  • Moves the 'Smiley Themes' Add/Remove? buttons to the right
  • Moves the 'Sound command' entry box to the right
  • Moves the 'stunserver.org' hint text to the right
  • Moves the 'End Port' entry to the right
  • Drops the Proxy and Browser config section when in GNOME

I know that creating two new tabs is kind of a cop-out, but I really didn't want to actually change any preferences, just move them. If the 'Sound Events' tab is too overboard, I can change the patch to keep the theme dropdown on the 'Sound' page but offer a button called 'Customize Sound Events' that opens a dialog with the sound events list. But I prefer the tab.

I think there is some more low-hanging fruit on the now-longest-pages by collapsing categories. The 'Interface' and 'Status/Idle?' pages in particular suffer from too many categories. But I'm not worrying about that now.

With this patch, on the Clearlooks theme, the dialog is about 680x525. And the two large lists in the dialog are much more readable, rather than being squished to a few lines (smiley theme list and sound events list).

The patch and screenshots of each tab are in the attached tarball.

comment:17 Changed 10 years ago by rekkanoryo

  • Milestone set to Patches Needing Review

comment:18 Changed 10 years ago by QuLogic

Ticket #9181 has been marked as a duplicate of this ticket.

comment:19 Changed 10 years ago by QuLogic

Ticket #8056 has been marked as a duplicate of this ticket.

comment:20 Changed 10 years ago by deryni

Ticket #10590 has been marked as a duplicate of this ticket.

comment:21 Changed 10 years ago by rekkanoryo

  • Resolution set to wontfix
  • Status changed from new to closed

I'm closing this ticket as wontfix because Elliott and I have already made a ton of changes ourselves (without the use of any of these patches) that reduce the size of the preferences window to 698x492 (WxH), which fits an 800x600 screen and should help tremendously with those ridiculously tiny netbook screens too. (Note the dialog will be slightly taller on Windows.)

comment:22 Changed 10 years ago by kstange

Not that it matters in the end, but I think this should be closed as "Fixed" rather than "Wontfix" because the issue reported was resolved, even if the original patches were not accepted.

I'd also like to thank mterry for his input which was certainly taken into account during these changes.

comment:23 Changed 10 years ago by deryni

  • Resolution wontfix deleted
  • Status changed from closed to new

Indeed, while a number of the changes here were not used some of the same changes were made. Further comments from mterry on things we could do to make pidgin better would be very welcome (our tardiness in dealing with the issues he raises notwithstanding).

comment:24 Changed 10 years ago by deryni

  • Resolution set to fixed
  • Status changed from new to closed

comment:25 Changed 10 years ago by mterry

Yeah, no hard feelings. :) Glad the issue got fixed.

comment:26 Changed 10 years ago by deryni

I meant what I said by the way, I'd love to hear what you have to say about the new preferences window. You can see screenshots here.

comment:27 Changed 10 years ago by mterry

Looks good! :) I like the move of tabs to the left. There were too many tabs to be horizontal (irrespective of vertical size).

comment:28 Changed 10 years ago by Robby

  • Milestone Patches Needing Review deleted

comment:29 Changed 10 years ago by rekkanoryo

  • Milestone set to 2.6.4

comment:30 Changed 10 years ago by dammbdf

Looks good deryni. You can get even more vertical space if you move the "Close" button under the tabs. (or if that button is a must on bottom right, to move the tabs on the right side) Great job.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!