Opened 12 years ago

Closed 8 years ago

#758 closed patch (patch_rejected)

Your own alias does not show up in chat rooms

Reported by: imiganai Owned by: rlaager
Milestone: Patches Needing Improvement Component: pidgin (gtk)
Version: 2.0 Keywords: chat, alias
Cc:

Description

When in a chat room, aliases you have set for other people in the room will show up as normal, which is fine. The issue is that the alias you set for yourself in the account settings does not show up in place of your user name on your own computer (as compared to one-on-one instant messaging, where it works properly). It should properly display your alias instead of your user name in the chat room text.

Attachments (1)

20070510_self_chat_alias.diff (1.1 KB) - added by SuperMMX 12 years ago.
set the normalized name as the chat nick when creating the chat

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by lschiere

  • Owner set to marv

comment:2 Changed 12 years ago by rlaager

  • Milestone set to 2.0.1
  • Owner changed from marv to rlaager

Changed 12 years ago by SuperMMX

set the normalized name as the chat nick when creating the chat

comment:3 Changed 12 years ago by SuperMMX

set the normalized name as the chat nick when creating the chat, then when adding self, alias will be set. Tested with MSN, don't know about others.

Can anyone take a look?

comment:4 Changed 12 years ago by rlaager

SuperMMX: I don't believe that patch is correct, because your display name can change, for example, on IRC. If I have an "rlaager" account created and I sign in when I'm signed in elsewhere, I'll end up with a display name of "rlaage1" even though the account username is still "rlaager".

comment:5 Changed 12 years ago by lschiere

  • Milestone changed from 2.0.1 to 2.0.2

comment:6 Changed 11 years ago by bernmeister

Should this ticket be moved to PatchesNeedingImprovement?

comment:7 Changed 11 years ago by rlaager

  • Milestone set to Patches Needing Improvement

comment:8 Changed 11 years ago by rlaager

Ticket #3664 has been marked as a duplicate of this ticket.

comment:9 Changed 10 years ago by robochief

Still remains as described in the ticket. Own e-mail address appear in the chat members.

comment:10 Changed 10 years ago by rekkanoryo

  • Type changed from defect to patch

comment:11 Changed 8 years ago by rekkanoryo

  • Resolution set to patch_rejected
  • Status changed from new to closed

Resolving this patch as "patch_rejected" because the issues mentioned here over a year ago have not been addressed. Anyone who wants to pick this patch up and improve it is more than welcome to do so.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!