Opened 10 years ago

Closed 10 years ago

#7625 closed defect (worksforme)

Bonjour support does not work with 64-bit Bonjour for Windows.

Reported by: mrmatt9595 Owned by: datallah
Milestone: Component: Bonjour
Version: 2.5.2 Keywords: bonjour,vista
Cc:

Description

Summary:
The Vista system cannot detect any other Bonjour chat-using systems on the network, even though others can see the Vista system, and cannot send or receive messages.

My setup:
I have four systems: two WinXP, one FreeBSD, and the Vista system. All systems have no firewall enabled, and run the latest Bonjour for Windows (or Avahi) and the latest Pidgin 2.5.2. The WinXP systems and the FreeBSD system can each communicate amongst each other without issues, each of the three can see the Vista system, and all can resolve the mDNS name of each of the others. However, the Vista system cannot see in Pidgin any other node or chat.

The kicker:
Miranda Local, a stripped-down version of Miranda with only Bonjour support, however, does work on the Vista system, including sight of other nodes and chat both ways, ruling out Apple's Bonjour as the cause of the problem.

Attachments (2)

purple-debug.log (643 bytes) - added by mrmatt9595 10 years ago.
winxp-debug.log (944 bytes) - added by mrmatt9595 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
This might be caused by the firewall configuration on the vista system.

Changed 10 years ago by mrmatt9595

comment:2 Changed 10 years ago by mrmatt9595

  • Status changed from pending to new

Attachment (purple-debug.log) added by ticket reporter.

comment:3 Changed 10 years ago by mrmatt9595

Here's the log showing when a WinXP system logs into Bonjour and then sends a message. The Vista system can ping the hostname listed in it.

Changed 10 years ago by mrmatt9595

comment:4 Changed 10 years ago by mrmatt9595

I attached as well a log from the WinXP computer's end when it sends a message to the Vista system. Both WinXP computers receive those messages when sending to the Vista system, yet both can communicate between each other.

comment:5 Changed 10 years ago by datallah

  • Status changed from new to pending

It looks like the problem is that resolving *.local doesn't work.

How did you install Bonjour for Windows?

Did you install the 32-bit or 64-bit version?

comment:6 Changed 10 years ago by mrmatt9595

  • Status changed from pending to new

I have discovered the root cause! I had installed the 64-bit version, and just reinstalled with the 32-bit version instead. Now it works.

comment:7 Changed 10 years ago by mrmatt9595

  • Summary changed from Bonjour support does not work on Vista x64 to Bonjour support does not work with 64-bit Bonjour

comment:8 Changed 10 years ago by datallah

  • Resolution set to worksforme
  • Status changed from new to closed
  • Summary changed from Bonjour support does not work with 64-bit Bonjour to Bonjour support does not work with 64-bit Bonjour for Windows.

I'm surprised that it got as far as it did with the 64-bit version - it must include a 32-bit dnssd library as well. Being a 32-bit application, Pidgin is going to need the appropriate 32-bit Bonjour library.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!