Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#7750 closed defect (worksforme)

wrong php version?

Reported by: AlexB Owned by: lschiere
Milestone: Component: winpidgin (gtk)
Version: 2.5.2 Keywords:
Cc:

Description

i just installed wamp which gave me a new php version. Which one do I need for pidgin?

Thanks!


Error occured on Wednesday, December 10, 2008 at 15:08:17.

Windows Version 5.1 Build 2600 Service Pack 3

C:\Program Files\Pidgin\pidgin.exe caused a Privileged Instruction at location 00fccef6 in module C:\wamp\bin\php\php5.2.7\aspell-15.dll.

Registers:

eax=635c5088 ebx=003e0178 ecx=00000063 edx=0022ebf2 esi=023d3c08 edi=003e6670

eip=00fccef6 esp=0022ecac ebp=0022ecd8 iopl=0 nv up ei ng nz na pe nc

cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00210282

Call stack:

00FCCEF6 C:\wamp\bin\php\php5.2.7\aspell-15.dll aerror_identical_option

635C26D0 C:\Program Files\Pidgin\libgtkspell.dll gtkspell_new_attach

C:\Program Files\Pidgin\pidgin.dll [2.5.2.0]

64ABA9BA C:\Program Files\Pidgin\pidgin.dll pidgin_setup_gtkspell c:/devel/pidgin-devel/pidgin-2.5.2/pidgin/gtkutils.c:930

64AB7AA8 C:\Program Files\Pidgin\pidgin.dll pidgin_status_box_init c:/devel/pidgin-devel/pidgin-2.5.2/pidgin/gtkstatusbox.c:1908

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.16.6.0]

63A5CAE4 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_type_create_instance

63A46787 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_object_new

63A45B99 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_object_newv

63A4658D C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_object_new_valist

63A46766 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_object_new

C:\Program Files\Pidgin\pidgin.dll [2.5.2.0]

64AB447A C:\Program Files\Pidgin\pidgin.dll pidgin_status_box_new c:/devel/pidgin-devel/pidgin-2.5.2/pidgin/gtkstatusbox.c:2120

64A58B11 C:\Program Files\Pidgin\pidgin.dll pidgin_blist_show c:/devel/pidgin-devel/pidgin-2.5.2/pidgin/gtkblist.c:5569

C:\Program Files\Pidgin\libpurple.dll [2.5.2.0]

67CC791B C:\Program Files\Pidgin\libpurple.dll purple_blist_show c:/devel/pidgin-devel/pidgin-2.5.2/libpurple/blist.c:707

C:\Program Files\Pidgin\pidgin.dll [2.5.2.0]

64A90650 C:\Program Files\Pidgin\pidgin.dll pidgin_main c:/devel/pidgin-devel/pidgin-2.5.2/pidgin/gtkmain.c:832

C:\Program Files\Pidgin\pidgin.exe [2.5.2.0]

00402362 C:\Program Files\Pidgin\pidgin.exe WinMain? c:/devel/pidgin-devel/pidgin-2.5.2/pidgin/win32/winpidgin.c:736

004029AA C:\Program Files\Pidgin\pidgin.exe WinMain? c:/devel/pidgin-devel/pidgin-2.5.2/pidgin/win32/winpidgin.c:523

00401247 C:\Program Files\Pidgin\pidgin.exe

004012B8 C:\Program Files\Pidgin\pidgin.exe

C:\WINDOWS\system32\kernel32.dll [5.1.2600.5512]

7C817067 C:\WINDOWS\system32\kernel32.dll RegisterWaitForInputIdle?

Attachments (1)

pidgin.RPT (2.7 KB) - added by nihil161 8 years ago.
RPN of crash on startup.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 8 years ago by deryni

pidgin doesn't care about php, this is being caused by the version of aspell that php is installing. I have no idea what the real issue is someone more familiar with our usage of gtkspell/aspell on Windows will have to chime in.

comment:2 Changed 8 years ago by AlexB

OK, thanks. I put a new version of aspell.dll in my pidgin directory and it's working now.

comment:3 Changed 8 years ago by deryni

A new version of aspell that you got from where? Was there previously an aspell.dll file in the pidgin directory or did you add one?

comment:4 Changed 8 years ago by datallah

  • Component changed from unclassified to winpidgin (gtk)
  • Resolution set to worksforme
  • Status changed from new to closed

The crash is inside aspell, so unfortunately there isn't a whole lot that we can do to prevent it.

I guess "wamp" is rudely replacing the default aspell installation with an incompatible version that has the same dll name, which is quite unfortunate.

Re-installing aspell manually (as covered in the FAQ) will resolve this type of issue.

comment:5 Changed 8 years ago by youngmug

I have the same behavior with the PHP 5.2.8 binary zip itself, so it isn't WAMP. I'm guessing that the PHP directory is early in the path, so the aspell DLL is being loaded from that directory. The binary distribution includes "aspell-15.dll" which 1,110,849 bytes in size.

If you aren't using the pspell extension in PHP (run phpinfo() in a script to check), simply renaming the aspell DLL should resolve the issue.

comment:6 Changed 8 years ago by rekkanoryo

Ticket #7853 has been marked as a duplicate of this ticket.

comment:7 Changed 8 years ago by datallah

Ticket #7875 has been marked as a duplicate of this ticket.

comment:8 Changed 8 years ago by datallah

Ticket #8611 has been marked as a duplicate of this ticket.

comment:9 Changed 8 years ago by datallah

Ticket #8669 has been marked as a duplicate of this ticket.

comment:10 Changed 8 years ago by darkrain42

Ticket #9004 has been marked as a duplicate of this ticket.

comment:11 Changed 8 years ago by rekkanoryo

Ticket #9133 has been marked as a duplicate of this ticket.

comment:12 Changed 8 years ago by datallah

Since this has become our "master" ticket for this issue, it is worth noting here that the correct solution is not to put the PHP directory in your PATH.

comment:13 Changed 8 years ago by rekkanoryo

Ticket #9170 has been marked as a duplicate of this ticket.

comment:14 Changed 8 years ago by rekkanoryo

Ticket #9469 has been marked as a duplicate of this ticket.

Changed 8 years ago by nihil161

RPN of crash on startup.

comment:15 Changed 7 years ago by datallah

Ticket #11749 has been marked as a duplicate of this ticket.

comment:16 Changed 7 years ago by datallah

Ticket #11756 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!