Opened 8 years ago

Closed 8 years ago

#7869 closed defect (invalid)

Copy + Paste functionality not working on external applications (windows)

Reported by: fmkaiba Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.5.3 Keywords: copy paste external


While this is close to a duplicate bug, its not exactly one, atleast none of the others cover this general issue.

Platform: Windows Vista x64 Ultimate Pidgin v2.5.3 (been occurring in previous versions too)

Steps to reproduce: 1) Copy any text from inside a chat window, info popup, log viewer etc, by selecting the text, right clicking, and clicking copy (or Ctrl + C) 2) Open Notepad/other Application 3) Paste

Expected result: The copied text from the clipboard is pasted into the application

Actual Result: Application cannot understand data in the clipboard, prevents pasting. Nothing happens

Reason Why: Pidgin saves copied text in a HTML block format for use internally in the application. (see attached) While windows expects plain text data.

Suggested Resolution: Add a 'Copy plain-text' feature to right click menu

Attachments (1)

Clipboard Snapshot.htm (170 bytes) - added by fmkaiba 8 years ago.
Saved pidgin text from the clipboard (a clipboard snapshot)

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by fmkaiba

Saved pidgin text from the clipboard (a clipboard snapshot)

comment:1 Changed 8 years ago by datallah

  • Status changed from new to pending

What you're seeing is a "standard" windows "HTML Format" clipboard snippet. It isn't just for internal use - the same thing happens when you copy and paste something from firefox.

However, we also copy a plain text version to the clipboard which applications that don't know how to handle the HTML Format can use (and it works fine for me with Notepad).

Which GTK+ version are you using (Help->About)?

comment:2 Changed 8 years ago by fmkaiba

  • Status changed from pending to new

Copying from firefox (both the x64 and x86 versions I have installed) shows copied text (from something like a text block) show the mime type HTML, Text. (I can attach snapshots if you want) where as copying from pidgin ends up in a HTML form only. (this is reproducible on multiple vista x64 machines)

I have encountered the same error in both the shipped GTK+ versions (2.12.12 I think), and (i thought upgrading might help) 2.14.5 (as 2.14.6 doesn't seem to be downloadable yet)

comment:3 Changed 8 years ago by fmkaiba

I did a little reading on what you linked too, the HTML format page.

I am seeing noticeable differences in the way pidgin copies, and for example firefox copies 'HTML Formats' i think the issue may be vista x64? i would like someone with vista 32 to test this if possible.

Here is what i have seen:

Pidgins format saves like:

Copy Test!

Where firefox saves like:

<!--StartFragment-->Copy Test!<!--EndFragment-->

The clipboard mime type for firefox's HTML also shows as HTML, Text (an attempt to make it universal between applications?)

where pidgin's indeed shows only HTML. (i cannot copy from pidgin to any other application, including firefox.) This problem is also exactly repeatable on a friends laptop (running a complete different set of apps, but also x64 vista)

Is there a reason for pidgin using a different copying form then firefox? why bump the version up to 1. instead of 0.9 too?

(i assume there was a change i am missing)

comment:4 Changed 8 years ago by datallah

It is possible that this issue only manifests itself on 64-bit Vista; I have no way of testing that (or debugging it, for that matter).

It does work for me on 32-bit Vista.

comment:5 Changed 8 years ago by datallah

I don't remember the details of why the version of 1.0 vs. 0.9 is used, however that isn't a recent change.

comment:6 Changed 8 years ago by fmkaiba

Its odd that that problem would only manifest itself in vista x64. changing the pidgin clipboard entry to match the way firefox saves it (mime type HTML, Text) and (Version 0.9 instead of 1.0) as well as adding the surrounded html, and body tags, causes it to work universally in every application.

comment:7 Changed 8 years ago by fmkaiba

  • Resolution set to invalid
  • Status changed from new to closed

I found the source of the problem.

I performed a trace of what was handling the clipboard data. The culpret was not pidgin, but an application i run called 'True Launch Bar' its clipboard manager did not understand the format pidgin was using, and handled it incorrectly. Though to note, it handles firefox's fine, so there is still some odd issue with the pidgin copy format. But overall this is not a serious issue.

changing to invalid, due to this not being a pidgin problem.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!