Opened 8 years ago

Closed 8 years ago

#8131 closed defect (fixed)

SSL/TLS bug due to old servers that don't follow xmpp spec

Reported by: bugdave Owned by: darkrain42
Milestone: 2.6.0 Component: XMPP
Version: 2.5.4 Keywords: jabber xmpp libpurple
Cc:

Description (last modified by bugdave)

libpurple seems to ignore the "require TLS/SSL" preference setting when connecting to ancient jabber servers that don't follow the xmpp spec. When connecting to a jabberd server on port 5222 with TLS/SSL required enabled, the TLS/SSL connection fails but libpurple still connects to the server without encryption.

Attachments (1)

2009-01-15.txt (2.9 KB) - added by bugdave 8 years ago.
used find and replace to hide certain details like jabber server ip/dns.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by bugdave

  • Description modified (diff)

comment:2 Changed 8 years ago by bugdave

  • Description modified (diff)

comment:3 Changed 8 years ago by deryni

  • Status changed from new to pending

Please follow these instructions to get a debug log and attach it to this ticket.

Changed 8 years ago by bugdave

used find and replace to hide certain details like jabber server ip/dns.

comment:4 Changed 8 years ago by bugdave

  • Status changed from pending to new

Attachment (2009-01-15.txt) added by ticket reporter.

comment:6 Changed 8 years ago by darkrain42

  • Owner changed from deryni to darkrain42

comment:7 Changed 8 years ago by darkrain42@…

  • Milestone set to 2.6.0
  • Resolution set to fixed
  • Status changed from new to closed

(In 55897c4ce0787edc1e7721b7f4a9b5cbc8357279):
Require SSL when trying IQ-auth via parser.c (no stream:features). Fixes #8131.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!