Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#8247 closed enhancement (fixed)

Support MSNP16 multiple logins

Reported by: tengblad Owned by: salinasv
Milestone: 2.7.6 Component: MSN
Version: Keywords: MSNP16
Cc: scytheman, tomgr, q10, Paradox, salinasv, Band_B, jisakiel, Dempsey, duyfken, d7415, jonatanschroeder, Universe_JDJ, MarkDoliner, voltagex, tpatteri, rkroetch, lowzl

Description

Hello,

I recently downloaded the newest version of Windows Live Messenger and noticed that it now supports the ability to log into MSN from more than one place at the same time. Is there any chance of this functionality being added to Pidgin as well? Since I use both a desktop (Windows PC) and Laptop (MacBook?) at home, this feature being included would cutting down on the amount of logging in logging out I have to do each day.

Attachments (1)

msnp16.patch (11.8 KB) - added by salinasv 9 years ago.
Initial msnp support

Download all attachments as: .zip

Change History (24)

comment:1 Changed 10 years ago by rekkanoryo

  • Summary changed from MSN: Sign in from more than one place to Support MSNP16 multiple logins

This requires that we support MSNP16 or newer.

comment:2 Changed 10 years ago by scytheman

this would be very useful for me, too. aMSN has implemented this. http://en.wikipedia.org/wiki/Microsoft_Notification_Protocol#MSNP16

cc me.

comment:3 Changed 10 years ago by daf

Same, I'm the same situation as the original poster.

comment:4 Changed 10 years ago by q10

Same. If we don't have what Windows Live Messenger has, we can never fully replace it, and new users will remain unconvinced to turn over to Pidgin.

comment:5 Changed 10 years ago by QuLogic

Ticket #8886 has been marked as a duplicate of this ticket.

comment:6 Changed 10 years ago by balupton

Agreed, using my Mac and PC at the same time, this would make it ideal. Instead I have to resort to Remote Desktop or VMWare Fusion solutions.

comment:7 Changed 9 years ago by rekkanoryo

  • Milestone set to Patches welcome

Thus far our MSN people have not had time to implement this. Anyone who wants it will need to step up and make it happen.

comment:8 Changed 9 years ago by QuLogic

  • Keywords more than one place removed
  • Milestone Patches welcome deleted
  • Owner changed from khc to salinasv

You're working on this now.

comment:9 Changed 9 years ago by salinasv

  • Keywords MSNP16 added

Just let you know, Now I can login, send and receive msgs.

I need to handle the multi presence properly.

(please, don't reply with "same", it just flood people's mails ;-) )

comment:10 Changed 9 years ago by duyfken

Could we have a update on the progress of this patch please?

I think this is becoming more relevant now as other third party MSN clients take up the feature (ie. Trillian Astra, aMSN as mentioned), so it'll help to keep Pidgin competitive if we could resolve this soon.

comment:11 Changed 9 years ago by Universe_JDJ

cc me

comment:12 Changed 9 years ago by salinasv

  • Type changed from enhancement to patch

It looks like I forgot to upload what I have done regarding msnp16. It's against kinda old i.p.p because I have that database on another box. Still it must be almost clean.

Changed 9 years ago by salinasv

Initial msnp support

comment:13 Changed 9 years ago by rekkanoryo

  • Milestone set to Patches Needing Review

comment:14 Changed 9 years ago by salinasv

  • Milestone changed from Patches Needing Review to Patches Needing Improvement
  • Version 2.5.4 deleted

This is far from complete. Just posted it to let you know the progress of the patch and maybe get some bug reports.

comment:15 Changed 9 years ago by qulogic@…

(In f88709dd4ccfa38136f3c8eb5575251494fa4aac):
Initial support for msnp16, based on patch by Masca.

References #8247.

comment:16 Changed 9 years ago by drunknmunky

Any further progress on this? It's the only thing holding me back from switching to Pidgin. I'd be happy to test the patch submitted if someone can explain to me how to apply it.

comment:17 Changed 9 years ago by salinasv

You can test it using the im.pidgin.cpw.qulogic.msnp16

Actually it can't receive/send emoticons and add people.

I'm sure it's a quick fix, just haven't the time to take a look.

comment:18 Changed 9 years ago by drunknmunky

I've been using it for a couple days now and although it's a start, there are a few more features needed before it can be released.

Conversations: Right now, if I have a conversation on another computer (WLM), it shows up as 2 separate conversations in Pidgin: 1 with messages from the person I'm talking to and 1 with messages that I write. The conversation will also stop receiving any messages at all sometimes.

Status: If the status is changed in Pidgin, other MSN locations' status changes as well. However, the reverse is not true: changing the status at another MSN location does not change Pidgin's status.

Multiple location management: It is not immediately obvious that the "View Locations" heading provides the opportunity to sign out of the other locations. Perhaps a submenu providing the opportunity to sign out of each/all locations and another entry to modify Pidgin's location name would work better.

Friendly name: Same problem as status: changes in Pidgin propagate to other clients but changes in other clients do not change the name in Pidgin.

Emoticons: I was able to use emoticons - I'm assuming you're referring to custom emoticons when you say it can't send/receive them. Didn't have the opportunity to test this.

Adding to contact list: Didn't have the opportunity to test adding someone.

FYI, I'm testing with the newest WLM running on another computer and the SVN version of aMSN and the msnp16 branch of Pidgin running locally.

comment:19 Changed 9 years ago by salinasv

  • Milestone changed from Patches Needing Improvement to Patches welcome
  • Type changed from patch to defect

I just want to add to the list some bugs this branch have and my guess about some of the bugs drunknmunky show up in a hope to get some patches.

  • For some reason official client when using MSNP16 is sending MSNObject with the Location empty and the filename encoded with Base64 in Friendly field. This caues to have not working anything that uses MSNObject: custom emoticons, displays picture, file transfers, etc.
  • Conversations: We need to manage swtichboard connection in a proper way. When we are logged in on different clients, all our instances join the switchboard, we receive one JOI requests from each active endpoint *and* the contact we are talking with. This means, actually we open a conversation with the contact and another one with ourselfs.
  • Add/remove accounts, I'm not sure but I think there will be no issue here.

comment:20 Changed 9 years ago by rekkanoryo

  • Milestone changed from Patches welcome to Implementation In Progress

comment:21 Changed 8 years ago by tpatteri

I really missing this feature when I'm using N900.

comment:22 Changed 8 years ago by salinasv

  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from defect to enhancement

The MSNP16 code is implemented in the im.pidgin.cpw.qulogic.msnp16 branch.

I'm closing this ticket so you can test it and file a ticket about any issue you find, I want this branch to get tested before merging it to im.pidgin.pidgin

comment:23 Changed 8 years ago by rekkanoryo

  • Milestone changed from Implementation In Progress to 2.7.6
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!