Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8328 closed defect (duplicate)

crash on tooltip of Sametime chat room

Reported by: kentyman Owned by: lschiere
Milestone: Component: unclassified
Version: 2.5.4 Keywords:
Cc:

Description

My Pidgin crashes a lot in Windows XP. I have the debug build installed, and will attach pidgin.RPT. Interestingly, I've noticed that many of these crashes occur when I mouse over my chat window when the current tab is a MUC in Sametime. I am also attaching screenshots of the tooltip having garbage characters instead of "Account:". Two of these screenshots show the crash, and you can use the timestamp in the filenames to match them up with the RPT. Interestingly, you can also see a screenshot where it did not crash even when there was jibberish. Additionally, I have screenshots where "Occupants: 3" is included, where the rest of the screenshots do not mention how many people are in the room.

Attachments (7)

pidgin.RPT (29.1 KB) - added by kentyman 10 years ago.
crash-2009-01-27T11-13-41.png (184.4 KB) - added by kentyman 10 years ago.
Screenshot of one of the crashes.
crash-2009-01-27T11-21-19.png (166.8 KB) - added by kentyman 10 years ago.
Screenshot of another one of the crashes.
nocrash-jibberish.png (92.0 KB) - added by kentyman 10 years ago.
Screenshot where there were garbage characters, but no crash.
nocrash-clean.png (94.3 KB) - added by kentyman 10 years ago.
Screenshot where everything looked good, but "Occupants" wasn't mentioned.
nocrash-occupants.png (116.2 KB) - added by kentyman 10 years ago.
Screenshot where everything looked good, and "Occupants" was mentioned.
pidgin.2.RPT (89.5 KB) - added by kentyman 10 years ago.
Crash still happens with 2.5.5.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by kentyman

Changed 10 years ago by kentyman

Screenshot of one of the crashes.

Changed 10 years ago by kentyman

Screenshot of another one of the crashes.

Changed 10 years ago by kentyman

Screenshot where there were garbage characters, but no crash.

Changed 10 years ago by kentyman

Screenshot where everything looked good, but "Occupants" wasn't mentioned.

Changed 10 years ago by kentyman

Screenshot where everything looked good, and "Occupants" was mentioned.

comment:1 Changed 10 years ago by datallah

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #8129.

comment:2 Changed 10 years ago by kentyman

Note that my RPT has lots of crashes, not all of which are related to the corrupt tooltip I mentioned before. In particular, not all of the crashes occur on startup. Are you sure that the two specific ones I show in crash*.png are really a duplicate of #8129, or did you just notice that at least one of my crashes was from that ticket? And what's with the "Occupants" inconsistency?

comment:3 Changed 10 years ago by datallah

There are a number of crashes; most of which appear to be caused by memory corruption of some variety.

The "Occupants" label will only appear while you're currently in the chat.

comment:4 Changed 10 years ago by kentyman

(RE: memory corruption: Sounds good.)

I was currently in the chat in all of those screenshots. You think this is a different bug?

comment:5 Changed 10 years ago by datallah

I have no reason to think that there is a bug related to the "Occupants" - the code would be have like that if you had gotten disconnected from the room. In the unblurred version of the screenshot, is the name surrounded in "(parens)"?

comment:6 Changed 10 years ago by kentyman

It was not in parens, and my name was listed on the right. As further "proof", these chat rooms always have exactly 3 people in them including myself (which you can see in the blurred versions).

I well get better screenshots tomorrow and, if indeed I was in the room, I will file another bug report (unless you recommend otherwise).

Changed 10 years ago by kentyman

Crash still happens with 2.5.5.

comment:7 Changed 10 years ago by kentyman

The last 3 crashes were with 2.5.5.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!