Opened 10 years ago

Closed 10 years ago

#8374 closed defect (duplicate)

msn crash when uploading buddy information

Reported by: kamikaze Owned by: khc
Milestone: Component: MSN
Version: 2.5.4 Keywords: msn ssl crash
Cc:

Description

I have switched msn accounts. To keep my buddy list I simply inserted the new account data into my old account in pidgin.

I'm running pidgin-2.5.4, on libpurple-2.5.4. I gather from the trace that it might be relevant that gnutls-2.6.3 is currently installed on my system.

(13:58:02) msn: Adding user censored@msn.com to group Battle Realms
(13:58:02) soap: POST //abservice/abservice.asmx HTTP/1.1
SOAPAction: http://www.msn.com/webservices/AddressBook/ABGroupContactAdd
Content-Type:text/xml; charset=utf-8
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Accept: */*
Host: omega.contacts.msn.com
Content-Length: 2058
Connection: Keep-Alive
Cache-Control: no-cache

<soap:Envelope xmlns:soap='http://schemas.xmlsoap.org/soap/envelope/' xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xmlns:xsd='http://www.w3.org/2001/XMLSchema' xmlns:soapenc='http://schemas.xmlsoap.org/soap/encoding/'><soap:Header><ABApplicationHeader xmlns='http://www.msn.com/webservices/AddressBook'><ApplicationId>CFE80F9D-180F-4399-82AB-413F33A1FA11</ApplicationId><IsMigration>false</IsMigration><PartnerScenario>ContactSave</PartnerScenario></ABApplicationHeader><ABAuthHeader xmlns='http://www.msn.com/webservices/AddressBook'><ManagedGroupRequest>false</ManagedGroupRequest><TicketToken>t=EwDIAcBdAAAU6YkiHMZzuZ4UDDW/bI8JLiYB/FmAAPYYTDWPdS8uO/ho3+HNkoXcvjauU6C7MKktt7O7fdYpJnXiKW47k+WBt3/0IO1Sa6jFQ3ZiF1mJr8OygJKLQk5FxSSe5fWrlN60cuBT0Z4K0LlJvjo1nS1Cx1qxaGtFHGG38+T1YvUTfshLsYO2NHTlqLY+7WgKttjWW+qYbvKTA2YAAAhe/KS84rKsUxgBJ8xHBGkQ8oRgnkgf7JbL82whmidlYOibMDMyVnPxlUNW2ra7tp4XSpkO2mp6EglHPjAsA7sdARDFAT4r/3eHrv4tg6VeEetkhuVnuGcUpnTfob/hy7ATMnNrfEPfgF63B2uASnSzusLhpdTIjmtfspDL+mTiY24ka7QDZIdaGc1/R1X4vVo5BvN+lcdvufZsxoeUIZ1CeaErM1BS5zOnc1wMauoUMy7c56mcq2ibO0C0XXuR9eJLn70bMew44Gd+L5hNAQPqVMw90DVcaVC3FsUk86UCCKara/fm54y1p1lf2K3/8uCQYaftDWrR0eRJbHljb0FkmTvgpdJFST7BGKWs4QR7OEW7aegUBX8rel9igpvdoGICvEMB&amp;p=</TicketToken></ABAuthHeader></soap:Header><soap:Body><ABGroupContactAdd xmlns='http://www.msn.com/webservices/AddressBook'><abId>00000000-0000-0000-0000-000000000000</abId><groupFilter><groupIds><guid>8ddd8fa0-a10d-4527-b454-e6baba948663</guid></groupIds></groupFilter><contacts><Contact><contactInfo><emails><ContactEmail><contactEmailType>Messenger3</contactEmailType><email>censored@msn.com</email><isMessengerEnabled>true</isMessengerEnabled><Capability>0</Capability><MessengerEnabledExternally>false</MessengerEnabledExternally><propertiesChanged/></ContactEmail></emails></contactInfo></Contact></contacts><groupContactAddOptions><fGenerateMissingQuickName>true</fGenerateMissingQuickName><EnableAllowListManagement>true</EnableAllowListManagement></groupContactAddOptions></ABGroupContactAdd></soap:Body></soap:Envelope>

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x804e02180 (LWP 100226)]
0x0000000808850e31 in msn_soap_write_cb_internal (data=0x80dd65080, fd=13, 
    cond=PURPLE_INPUT_WRITE, initial=0) at soap.c:544

544		written = purple_ssl_write(conn->ssl, conn->buf->str + conn->handled_len,
(gdb) dns[89952]: nobody needs me... =(
bt
#0  0x0000000808850e31 in msn_soap_write_cb_internal (data=0x80dd65080, fd=13, 
    cond=PURPLE_INPUT_WRITE, initial=0) at soap.c:544
#1  0x0000000808850fc0 in msn_soap_write_cb (data=0x80dd65080, fd=13, 
    cond=PURPLE_INPUT_WRITE) at soap.c:580
#2  0x000000000046d461 in pidgin_io_invoke (source=0x80ddf3700, 
    condition=G_IO_OUT, data=0x80de21ec0) at gtkeventloop.c:78
#3  0x0000000803f6556a in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.0
#4  0x0000000803f684d5 in g_main_context_check ()
   from /usr/local/lib/libglib-2.0.so.0
#5  0x0000000803f68808 in g_main_loop_run ()
   from /usr/local/lib/libglib-2.0.so.0
#6  0x000000080112530c in gtk_main () from /usr/local/lib/libgtk-x11-2.0.so.0
#7  0x000000000048a258 in main (argc=1, argv=0x7fffffffea38) at gtkmain.c:884
(gdb)

Change History (1)

comment:1 Changed 10 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #7508.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!