Opened 10 years ago

Last modified 10 years ago

#8446 new defect

Windows client always uses status from exit on startup

Reported by: arnold Owned by: deryni
Milestone: Component: libpurple
Version: 2.5.4 Keywords:
Cc:

Description

Whenever the windows client starts (on Windows XP SP3) it uses the status from exit, instead of taking into account the option in preferences, "Use status from last exit on startup." Additionally, the box to specify what status should be used on startup is consistently blank after closing the dialog.

Attachments (13)

changeprefs.log (2.1 KB) - added by arnold 10 years ago.
log of changing setting, setting away status
startupdebug.log (12.9 KB) - added by arnold 10 years ago.
log of starting up after having changed settings and set to away
1._prefs.xml_set_to_use_last_status_on_startup (16.9 KB) - added by arnold 10 years ago.
2._prefs.xml_after_loading_pidgin_with_prefs.xml_set_to_use_last_status_on_startup (16.9 KB) - added by arnold 10 years ago.
3._prefs.xml_after_unchecking_use_last_status_on_startup (16.9 KB) - added by arnold 10 years ago.
4._prefs.xml_after_a_minute_aftr_unchecking_use_last_status_on_startup (16.9 KB) - added by arnold 10 years ago.
5._prefs.xml_after_closing_after_unchecking_use_last_status_on_startup (16.9 KB) - added by arnold 10 years ago.
6._prefs.xml_after_restarting (16.9 KB) - added by arnold 10 years ago.
7._prefs.xml_after_setting_status_to_away,_testing (16.9 KB) - added by arnold 10 years ago.
8._prefs.xml_after_closing (16.9 KB) - added by arnold 10 years ago.
9._prefs.xml_after_restarting (16.9 KB) - added by arnold 10 years ago.
10._prefs.xml_after_setting_status_to_apply_at_startup_to_away (16.9 KB) - added by arnold 10 years ago.
11._prefs.xml_a_minute_later (16.9 KB) - added by arnold 10 years ago.

Download all attachments as: .zip

Change History (24)

comment:1 Changed 10 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.
This works fine for me.

What do you mean that the box "is consistently blank"?

Changed 10 years ago by arnold

log of changing setting, setting away status

comment:2 Changed 10 years ago by arnold

  • Status changed from pending to new

Attachment (changeprefs.log) added by ticket reporter.

Changed 10 years ago by arnold

log of starting up after having changed settings and set to away

comment:4 Changed 10 years ago by arnold

By "consistently blank" I mean that whenever I change it, it reverts to being blank. It sometimes reverts after I close the preferences window and once took until I restarted the program, but it always returns to being blank.

I attached debug logs of changing the item in preferences (which shows that it saves the file), then setting my status to away and quitting.

Next, I started the program. I expunged the log of the buddy status lines.

comment:5 Changed 10 years ago by deryni

  • Status changed from new to pending

What does the prefs.xml file say when the dropdown is empty? What does it say immediately after pidgin writes the file to disk when you make the change? What does it say a minute after that? What does it say once you quit pidgin? What does it say when you start pidgin back up again? What status are you choosing from the dropdown?

comment:6 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Changed 10 years ago by arnold

Changed 10 years ago by arnold

Changed 10 years ago by arnold

Changed 10 years ago by arnold

comment:7 Changed 10 years ago by arnold

I uploaded a bunch of prefs.xmls. Using Windows at the moment prohibited me from doing diffs easily, as all I have is kdiff3, which apparently won't give UNIX diff-style output anywhere. Everything looks like it should work. The iffy thing is that even when I have it set to use a specific status on startup, changing my status changes the "startup" pref.

comment:8 Changed 10 years ago by darkrain42

  • Status changed from closed to new

comment:9 Changed 10 years ago by QuLogic

  • Owner changed from lschiere to rekkanoryo

comment:10 follow-up: Changed 10 years ago by bernmeister

Sounds like a duplicate of #8426...and if so...#8426 maybe shouldn't be closed. Could be a coincidence though that this has happened two times close to each other.

comment:11 in reply to: ↑ 10 Changed 10 years ago by arnold

Replying to bernmeister:

Sounds like a duplicate of #8426...and if so...#8426 maybe shouldn't be closed. Could be a coincidence though that this has happened two times close to each other.

I believe it is the same issue. I'm surprised I didn't manage to find that one when I searched before creating this issue. The person there solved it by changing something in his or her prefs.xml. The issue is that pidgin is not doing that itself, for some reason. That's a workaround, but I think the real issue should remain open (whichever bug report it is doesn't matter to me).

comment:12 Changed 10 years ago by deryni

  • Component changed from unclassified to libpurple
  • Owner changed from rekkanoryo to deryni
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!