Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#8508 closed defect (fixed)

International UTF-8 display name can set at about 30-40 chars less than Windows Live client

Reported by: chalet16 Owned by: khc
Milestone: 2.7.8 Component: MSN
Version: 2.5.2 Keywords:
Cc:

Description

On my Windows Live client I can set my display name at 130 characters but when I use Pidgin I can set my display name to only about 30-40 characters for international languages. I try to use Wireshark to sniff communication and I found that Pidgin use url encoding with my display name but Windows Live Messenger send UTF-8 without url encoding

I have already show this problems in aMSN forums http://www.amsn-project.net/forums/viewtopic.php?p=32145 . It is in both aMSN and Pidgin.

PS.Sorry for my bad english. Thanks

Change History (2)

comment:1 Changed 8 years ago by qulogic@…

  • Milestone set to 2.7.8
  • Resolution set to fixed
  • Status changed from new to closed

(In 9116aec2b9157c0500ab9560d849627e1f9ea2e6):
Stop escaping all characters in the display name. It's only necessary to escape percent and space, and the UTF-8 can be left alone.

Fixes #8508.

comment:2 Changed 8 years ago by QuLogic

Ticket #12733 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!