Opened 10 years ago

Closed 10 years ago

#8533 closed defect (duplicate)

Pidgin crashes immediately on startup - Vista 32bit

Reported by: onihunter Owned by: lschiere
Milestone: Component: unclassified
Version: 2.5.4 Keywords: crash, startup
Cc:

Description

Recently, whenever I try to start up Pidgin, it crashes without showing any windows or anything. I've tried restarting my computer and uninstalling/reinstalling Pidgin but to no avail.

pidgin.RPT file:


Error occured on Friday, February 27, 2009 at 23:24:19.

Windows Version 6.0 Build 6000

C:\Program Files\Pidgin\Pidgin.exe caused an Access Violation at location 68dde218 in module C:\Program Files\Common Files\GTK\2.0\bin\libcairo-2.dll Reading from location 00000004.

Registers: eax=0022736e ebx=00227380 ecx=757ea0a4 edx=0022736e esi=00000000 edi=03816460 eip=68dde218 esp=00227260 ebp=002272a8 iopl=0 nv up ei pl nz na po nc cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00210206

Call stack: 68DDE218 C:\Program Files\Common Files\GTK\2.0\bin\libcairo-2.dll cairo_scaled_font_text_extents 6D4C22DC C:\Program Files\Common Files\GTK\2.0\bin\libpangocairo-1.0-0.dll pango_cairo_font_get_scaled_font 6D4C2AFC C:\Program Files\Common Files\GTK\2.0\bin\libpangocairo-1.0-0.dll pango_cairo_font_get_scaled_font

C:\Program Files\Common Files\GTK\2.0\bin\libpangowin32-1.0-0.dll [1.22.2.0]

6B2870EA C:\Program Files\Common Files\GTK\2.0\bin\libpangowin32-1.0-0.dll _pango_win32_fontmap_cache_remove 6B287355 C:\Program Files\Common Files\GTK\2.0\bin\libpangowin32-1.0-0.dll _pango_win32_fontmap_cache_remove

C:\Program Files\Common Files\GTK\2.0\bin\libpango-1.0-0.dll [1.22.2.0]

6559D530 C:\Program Files\Common Files\GTK\2.0\bin\libpango-1.0-0.dll pango_shape 65590703 C:\Program Files\Common Files\GTK\2.0\bin\libpango-1.0-0.dll pango_layout_iter_get_baseline 65590E90 C:\Program Files\Common Files\GTK\2.0\bin\libpango-1.0-0.dll pango_layout_iter_get_baseline 65593363 C:\Program Files\Common Files\GTK\2.0\bin\libpango-1.0-0.dll pango_layout_line_get_pixel_extents 65594207 C:\Program Files\Common Files\GTK\2.0\bin\libpango-1.0-0.dll pango_layout_line_get_pixel_extents

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61910B0D C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_text_layout_get_line_display 61911BFC C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_text_layout_set_overwrite_mode 618F616E C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_text_mark_set_visible 6190F4CD C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_text_layout_validate_yrange 619236B5 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_text_view_new_with_buffer 61923BEF C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_text_view_scroll_to_iter 61926487 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_text_view_scroll_mark_onscreen

C:\Program Files\Pidgin\pidgin.dll [2.5.4.0]

64A7E2CC C:\Program Files\Pidgin\pidgin.dll gtk_imhtml_size_allocate c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/gtkimhtml.c:397

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate 618C8BBC C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_scrolled_window_get_shadow_type

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate 61979DB1 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_vbox_new

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate 6181E366 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_frame_get_shadow_type

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate 61979DB1 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_vbox_new

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate

C:\Program Files\Pidgin\pidgin.dll [2.5.4.0]

64AB4CFD C:\Program Files\Pidgin\pidgin.dll pidgin_status_box_size_allocate c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/gtkstatusbox.c:2051

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate 61979DB1 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_vbox_new

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate 61885323 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_notebook_set_tab_label_text

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate 61979DB1 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_vbox_new

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate 61996504 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_window_reshow_with_initial_size

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61982BB3 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_size_allocate 61999211 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_window_get_position

C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll [2.18.3.0]

63A43955 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_closure_invoke 63A57882 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_has_handler_pending 63A58BF1 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit_valist 63A58E76 C:\Program Files\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll g_signal_emit

C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll [2.14.6.0]

61988934 C:\Program Files\Common Files\GTK\2.0\bin\libgtk-win32-2.0-0.dll gtk_widget_realize

C:\Program Files\Pidgin\pidgin.dll [2.5.4.0]

64A58F39 C:\Program Files\Pidgin\pidgin.dll pidgin_blist_show c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/gtkblist.c:5639

C:\Program Files\Pidgin\libpurple.dll [2.5.4.0]

67CC797B C:\Program Files\Pidgin\libpurple.dll purple_blist_show c:/devel/pidgin-devel/pidgin-2.5.4/libpurple/blist.c:708

C:\Program Files\Pidgin\pidgin.dll [2.5.4.0]

64A90900 C:\Program Files\Pidgin\pidgin.dll pidgin_main c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/gtkmain.c:828

C:\Program Files\Pidgin\Pidgin.exe [2.5.4.0]

004023EC C:\Program Files\Pidgin\Pidgin.exe WinMain? c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/win32/winpidgin.c:749 00402A4A C:\Program Files\Pidgin\Pidgin.exe WinMain? c:/devel/pidgin-devel/pidgin-2.5.4/pidgin/win32/winpidgin.c:628 00401247 C:\Program Files\Pidgin\Pidgin.exe 004012B8 C:\Program Files\Pidgin\Pidgin.exe

C:\Windows\system32\kernel32.dll [6.0.6000.16386]

76803833 C:\Windows\system32\kernel32.dll BaseThreadInitThunk?

C:\Windows\system32\ntdll.dll [6.0.6000.16386]

76F5A9BD C:\Windows\system32\ntdll.dll LdrInitializeThunk?

Attachments (1)

Pidgin.RPT (11.9 KB) - added by onihunter 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by onihunter

comment:1 Changed 10 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #8129.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!