Opened 10 years ago

Closed 10 years ago

#8757 closed defect

Windows Visual Style Bug(s)

Reported by: coojoe89 Owned by:
Milestone: Component: pidgin (gtk)
Version: 2.5.5 Keywords: visual styles, theme
Cc: datallah

Description (last modified by coojoe89)

Love pidgin, but ever since i've started using a different windows theme i've had several problems.

This problem (http://developer.pidgin.im/ticket/4979) still occurs for me. And on certain occasions after maximizing from tray i get(Hosted using HDimage.org): http://hdimage.org/images/qi51kok6vx0upjy63ok_pdscr.png

What exactly is wrong in that screenshot?

There's an outer square box around the pidgin window. I've noticed that sometimes it looks like the pidgin window was placed over another and then someone cropped it in a rectangle (so you have the remnants of something in that background square) Not a huge thing but its a bit of an eyesore.

Using Windows XP and this theme: http://lassekongo83.deviantart.com/art/Coral-VS-114497926

Change History (9)

comment:1 Changed 10 years ago by coojoe89

  • Description modified (diff)

comment:2 Changed 10 years ago by coojoe89

  • Description modified (diff)

comment:3 Changed 10 years ago by deryni

  • Status changed from new to pending

What exactly is wrong in that screenshot? I'm afraid I don't see anything immediately obviously broken. Is the problem that the status selector appears to be using the default Windows theme?

What font and font size do you have Windows set up to use?

comment:4 Changed 10 years ago by coojoe89

  • Status changed from pending to new

What exactly is wrong in that screenshot?

There's an outer square box around the pidgin window. I've noticed that sometimes it looks like the pidgin window was placed over another and then someone cropped it in a rectangle (so you have the remnants of something in that background square)

What font and font size do you have Windows set up to use?

The theme uses "Segoe UI" for a font. No size is listed.

Interesting, i took an alt-prscr screenshot of my display properties window and check out what I got: http://i44.tinypic.com/2qmdabc.jpg In the very top you can see a tiny sliver of my desktop, Leading me to believe the theme, being slightly smaller than the windows default, uses some sort of transparency. The altprintscreen takes that entire window based on the windows xp default size and is forced to capture that extra area that the theme makes transparent. So perhaps it's a quirk with this particular theme

comment:5 Changed 10 years ago by coojoe89

  • Description modified (diff)

comment:6 Changed 10 years ago by deryni

  • Status changed from new to pending

Window borders are drawn by Windows, not by GTK+ so if the problem is with the window borders then the problem isn't with GTK+. It is of course possible that if window sizing/placement is related to the problem that GTK+ is interacting with Windows to exacerbate the problem.

I am by no means a Windows expert but I was reasonably sure that the "Font size:" dropdown was supposed to contain size choices (namely "Normal", "Large", and "Extra Large") and not font faces. Assuming there isn't some feature I'm missing here it seems to me that something is rather confused on your computer, which may be the fault of the theme I really couldn't say. What other options are listed in that dropdown with your current theme?

comment:7 Changed 10 years ago by coojoe89

  • Status changed from pending to new

Yes i agree, but no other programs give me this problem. So logically it must be something in the way pidgin is handling windows/this theme.

Other options on that list are Tahoma and Trebuchet. I just tried switching it to Tahoma and currently things have gone back to normal. I have no idea why, I'll continue to use this 'setting' and see what happens.

comment:8 Changed 10 years ago by deryni

  • Status changed from new to pending

What order are the options in the "Font size" dropdown listed in? Which is first, etc.?

comment:9 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!