Opened 10 years ago

Closed 10 years ago

#8819 closed defect (duplicate)

Pidgin will "auto-raise" window on XMPP messages

Reported by: Lobsang Owned by: lschiere
Milestone: Component: XMPP
Version: 2.5.5 Keywords: xmpp, raise conversation
Cc:

Description (last modified by deryni)

After upgrading to 2.5.5, messages received from other users using libpurple (pidgin, adium, etc) will cause the conversation window to open (and raise) even though pidgin is set to not do so.

Initially, I thought this could be related to the OTR plugin, but the problem happens even after I disabled all plugins and restarted pidgin.

Here's a sample XMPP message that causes it (formatting added for ease of viewing):

(This is the user beginning to type. At this point, everything is normal and the window is not improperly raised)

<message type='chat' id='purplea7829a0d'
         to='foo@bar.com/TritonA401F236'
         from='moo@cow.com/AdiumEC1CEF28'>
  <composing xmlns='http://jabber.org/protocol/chatstates'/>
  <x xmlns='google:nosave' value='disabled'/>
  <record xmlns='http://jabber.org/protocol/archive'
   otr='false'/>
</message>

(This is when the problem happens)

<message type='chat' id='purplea7829a0e'
         to='foo@bar.com/TritonA401F236'
         from='moo@cow.com/AdiumEC1CEF28'>
  <active xmlns='http://jabber.org/protocol/chatstates'/>
  <body>This is a test message</body>
  <html xmlns='http://jabber.org/protocol/xhtml-im'>
  <body xmlns='http://www.w3.org/1999/xhtml'>
    This is a test message</body>
  </html>
  <x xmlns='google:nosave' value='disabled'/>
  <record xmlns='http://jabber.org/protocol/archive' otr='false'/>
</message>

I'm no expert in XMPP, but is it normal to have the message being sent twice, once in "plain-text" and again inside an HTML container?

I tried the same using the Google web talk client and the problem does not happen.

-- Lob

Change History (4)

comment:1 Changed 10 years ago by deryni

  • Description modified (diff)
  • Status changed from new to pending

Yes, it is normal to have both plain and xhtml-im message blocks, though applications are supposed to only send the xhtml-im block when there is formatting involved, which pidgin doesn't currently do.

Does this happen for all messages from all buddies? Does it only happen on certain protocols? Does it only happen for certain buddies? Do you have the message notification plugin loaded? If so, what options do you have enabled in it?

Can you get the message stanza from the Google Talk web client that doesn't trigger this issue?

Does this issue go away if you disable custom smileys for your XMPP account? That option is in the Modify Account dialog.

comment:2 Changed 10 years ago by Lobsang

  • Status changed from pending to new

Hi,

I *think* disabling the custom icons fixed the problem. I tested it by sending myself a message (across accounts), and it seems to work.

The irony of this is that I reported this exact same problem a while ago (Ticket#3627), but for MSN. Back then, I found a workaround by looking at the source and disabled the custom icons in the config file (at the time, the disable dialog was not available, IIRC). Since then, I started using XMPP, and custom icons were not disabled for this account.

I'll give the bug one or more two days and see if I can find some friends to test it with. I think it will work and if so, I'll close this bug.

Many Thanks
-- Lob

comment:3 Changed 10 years ago by Lobsang

Confirmed that disabling custom icons in the Accounts/Manage? accounts/Advanced screen fixed the problem.

Should I close the bug? This is clearly a bug, but the workaround is simple.

comment:4 Changed 10 years ago by darkrain42

  • Component changed from unclassified to XMPP
  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #7380.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!