Opened 9 years ago

Closed 8 years ago

#8917 closed defect

entering/displaying chinese all stopped working (2.5.5 on XPSP3)

Reported by: craigh Owned by: rekkanoryo
Milestone: Component: unclassified
Version: 2.5.5 Keywords: chinese language support broken
Cc:

Description

As of upgrading to 2.5.5 (download/install Pidgin) on XPSP2, all chinese support is gone. Had been working nicely for many versions prior to this. Have searched KB and Tickets extensively, no clues.

A few references to "pango" - downloaded latest from pango.org, and observed that dll's and exe's in that ZIP file are NOT present on my machine, so, didn't have anything to replace.

Have re- re-installed Pidgin 2.5.5 already - still get same results.

Any ideas?

Change History (10)

comment:1 Changed 9 years ago by inpidgin

I don't know,but the follows may be useful:
Ticket 604

comment:2 Changed 8 years ago by craigh

This is not applicable. Chinese supported worked fine before upgrading to 2.5.x. All upgrades since then have destroyed Chinese support for messages, buddy displays, information displays, and hovers. I.e. nothing works.

All other Chinese support on my XPSP2 system continue to work fine.

Time for Trillian? I have too many Chinese friends and co-workers with whom I must converse in Chinese.

comment:3 Changed 8 years ago by deryni

  • Status changed from new to pending

What exactly is happening when it doesn't work? What are you seeing instead of the correct characters?

comment:4 Changed 8 years ago by craigh

  • Status changed from pending to new

just the ordinary boxes with four hexidecimal digits inside (representing the Unicode character number of course).

comment:5 Changed 8 years ago by QuLogic

  • Owner changed from lschiere to rekkanoryo

comment:6 Changed 8 years ago by bernmeister

I suspect #8917, #9635 and #9950 are duplicates of #604.

comment:7 Changed 8 years ago by darkrain42

Ticket #9635 has been marked as a duplicate of this ticket.

comment:8 Changed 8 years ago by darkrain42

Ticket #9950 has been marked as a duplicate of this ticket.

comment:9 Changed 8 years ago by darkrain42

  • Status changed from new to pending

I think it's probable a GTK change (or theme change) changed the default document and conversation font in Pidgin to one which can't handle Chinese glyphs.

The comments on #604 contain a number of possible workarounds for this.

comment:10 Changed 8 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!