Opened 10 years ago

Closed 10 years ago

#8982 closed defect (duplicate)

crash on shutdown

Reported by: Firewave Owned by: lschiere
Milestone: Component: unclassified
Version: 2.5.5 Keywords:
Cc:

Description

Recently I started having crashes on shutdown with Pidgin 2.5.5. The only recent change was, that I disabled, but didn't delete my ICQ account. Beside that I have two active IRC accounts and one active MySpace? account.

Here is the backtrace:

Program received signal SIGSEGV, Segmentation fault.
populate_menu_with_options (menu=0x3d14470, gtkconv=0x248af10, all=0)
    at gtkconv.c:3217
3217    gtkconv.c: No such file or directory.
        in gtkconv.c
(gdb) bt full
#0  populate_menu_with_options (menu=0x3d14470, gtkconv=0x248af10, all=0)
    at gtkconv.c:3217
        components = (GHashTable *) 0x0
        account = (PurpleAccount *) 0x24782a0
        prpl = (PurplePlugin *) 0x0
        prpl_info = (PurplePluginProtocolInfo *) 0x4c069d8
        list = (GList *) 0x0
        conv = (PurpleConversation *) 0x3d344c8
        node = (PurpleBlistNode *) 0x0
        chat = (PurpleChat *) 0x0
        buddy = (PurpleBuddy *) 0x0
        ret = 63220480
#1  0x64a60bad in regenerate_options_items (win=0x0) at gtkconv.c:3302
        menu = (GtkWidget *) 0x248af10
        gtkconv = (PidginConversation *) 0x248af10
        list = (GList *) 0x3d344c8
#2  0x64a6bc5a in switch_conv_cb (notebook=0x3d15460, page=0x3c37ab8,
    page_num=0, user_data=0x4a46c20) at gtkconv.c:8945
        win = (PidginWindow *) 0x4a46c20
        conv = (PurpleConversation *) 0x3d344c8
        gtkconv = (PidginConversation *) 0x248af10
        sound_method = 0xffffffff <Address 0xffffffff out of bounds>
        __PRETTY_FUNCTION__ = "switch_conv_cb"
        page_num = 0
#3  0x63a43955 in g_closure_invoke ()
   from C:\Program Files (x86)\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll
No symbol table info available.
#4  0x63a58275 in signal_emit_unlocked_R ()
   from C:\Program Files (x86)\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll
No symbol table info available.
#5  0x00000000 in ?? ()
No symbol table info available.

Change History (1)

comment:1 Changed 10 years ago by QuLogic

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #8774.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!