Opened 7 years ago

Closed 5 months ago

#8988 closed defect (out of date)

"Unable to add user"

Reported by: blargg Owned by: khc
Milestone: Component: MSN
Version: 2.5.5 Keywords:
Cc: doublehp, cyberience, mmatos

Description

Unable to add user

Unknown error (204)


this appears while starting up pidgin. Doesn't show up otherwise. I believe it has something to do with the facebook account. I did revert back to an old version of a buddylist with that account no longer active, and I still receive the issue.

Attachments (4)

asdf.JPG (10.3 KB) - added by blargg 7 years ago.
Error message
purple-debug.log (210.4 KB) - added by blargg 7 years ago.
Adium___.png (19.9 KB) - added by mustangxu 7 years ago.
Got the same issue under mac, using Adium
MSN_connection_issue.jpg (20.9 KB) - added by davidmarshall15 4 years ago.
Error when connection to MSN with a username like "username@…"... Yes my Microsoft MSN username does end with yahoo.co.uk!

Download all attachments as: .zip

Change History (37)

Changed 7 years ago by blargg

Error message

comment:1 Changed 7 years ago by datallah

  • Status changed from new to pending

Please follow the instructions to get a debug log and attach it to this ticket.

Changed 7 years ago by blargg

comment:2 Changed 7 years ago by blargg

  • Status changed from pending to new

Attachment (purple-debug.log) added by ticket reporter.

comment:3 Changed 7 years ago by blargg

Found the error in the log, it's stated as an ADL error with MSN protocol. What do I do?

comment:4 Changed 7 years ago by datallah

  • Component changed from pidgin (gtk) to MSN
  • Owner set to khc

comment:5 Changed 7 years ago by igordcard

It started appearing to me too after I added some contacts in my contact list while my internet connection was unstable (always going down and up), and so I added multiple times some contacts. Since then I couldn't fix this error.

comment:6 Changed 7 years ago by QuLogic

If you check the debug log, the error is for ADL 19, which is for an @yahoo.de address. According to this page, the FQY response should have returned an actual="email@yahoo.com" attribute that we should use when referring to that contact on the server.

I don't know how far this extends; presumably for ADL and RML, and I'd guess for UUM/UBM. The AB would probably use the original address. Is there anywhere else we'd need to check?

comment:7 Changed 7 years ago by khc@…

(In 706a83709228c4f9330ad89c170026fcf6cedaaa):
re-enable something that qulogic wrote but commented out because of a previous string freeze, makes us display the textual ADL error if possible

References #8988

comment:8 Changed 7 years ago by tjb300

I have updated to Adium 1.4b1 and the error has changed from that in the attached file to

Unknown error (204): <ml><d n="yahoo.co.uk"><c n="need_4_5peed" l="3" t="32" /></d></ml>

That username corresponds to someone on my MSN contact list, so maybe it has something to do with syncronisation between Yahoo and MSN?

comment:9 Changed 7 years ago by QuLogic

Some more info from msnp-sharp:

1. The email address is anyyahoouser@yahoo.com.TR
2. Send a FQY command whether this user a yahoo user:
    <ml><d n="yahoo.com.TR"><c n="anyyahoouser" /></d></ml>
3. You will receive a response, see actual attribute:
    <ml><d n="yahoo.com.TR"><c n="anyyahoouser" t="32" actual="anyyahoouser@yahoo.com" />
4. "t" is type (optional), if this attribute exists, this is a real yahoo user. "actual" (optional) is real yahoo! messenger address to add.
  4.1 Add actual address if the field exists, otherwise add <d> and <c>
  4.2 Add also original address as other mail (but not messenger) as ContactEmailTypeType.ContactEmailOther.

I'm not sure if we can handle this properly just yet. We pretty much ignore ContactEmailOther as far as I know, and auto-switching to the "actual" address might be bad as we use it as the buddy in purple (i.e. for log directories, merging, other core stuff).

Changed 7 years ago by mustangxu

Got the same issue under mac, using Adium

comment:10 Changed 7 years ago by mustangxu

I got the same issue under mac, using Adium. The dialog popups every time I logged in and it's really annoying, any walk-around?

comment:11 Changed 7 years ago by Robby

  • For Adium users:

From the "Known Issues" thread on Adium's forums:

"workaround: remove the Yahoo contact that is causing it.
Find out which one it is by getting a debug log
(see http://trac.adium.im/wiki/CurrentAdiumDebug for instructions)."

comment:12 Changed 7 years ago by cyberience

Would appear there is some fundamental problem here, that is overlooked, This problem happens to me, in both Vista and XP, on 2 separate machines, if I use Trillian, I have no such issue, and the MSN/Yahoo works fine. Any solution yet? I am using both 2.58 and 2.6.

comment:13 Changed 7 years ago by luiscastilho

Had the same problem trying to add a Yahoo contact (*@yahoo.com.br). Running Pidgin 2.6.2 under Windows XP SP3.

comment:14 Changed 7 years ago by radiobuzzer

Same error here, when adding an MSN contact, with *@yahoo.co.uk . The error occurs when the contact is added, giving a message "Unable to add user, error 204". But the contact is indeed added, and stays in the offline contact. Then it gets repeated, the same message, every time I log in MSN network.

I believe that the problem may have to do with the fact that the contact remains added, although the network is giving a message when it is added at the first place.

comment:15 Changed 7 years ago by radiobuzzer

Forgot to mention, running Pidgin 2.5.8 on Ubuntu Jaunty

comment:16 Changed 6 years ago by QuLogic

Ticket #11556 has been marked as a duplicate of this ticket.

comment:17 Changed 6 years ago by QuLogic

Ticket #12010 has been marked as a duplicate of this ticket.

comment:18 in reply to: ↑ description Changed 6 years ago by v3gard

Replying to blargg:

Unable to add user

Unknown error (204)


this appears while starting up pidgin. Doesn't show up otherwise. I believe it has something to do with the facebook account. I did revert back to an old version of a buddylist with that account no longer active, and I still receive the issue.

I get the same error with Pidgin 2.7.0 (libpurple 2.7.0). Unknown error (204): <ml><d n="yahoo.no"><c n="vidar<part of username undisclosed>" l="3" t="32" /></d></ml>.

comment:19 Changed 6 years ago by QuLogic

Ticket #12502 has been marked as a duplicate of this ticket.

comment:20 Changed 5 years ago by RichardB

having same issue with pidgin 2.7.9 on both windows 7 and ubuntu 10.10 added a "@yahoo.com.br" contact and every time I log in (no matter what machine that is) I get the error. Already removed the contact but I still get this:

"Erro desconhecido (204): <ml><d n="yahoo.com.br"><c n="[...]" l="3" t="32" /></d></ml>"

comment:21 Changed 5 years ago by HtheB

I have the same issue with adding a buddy on MSN now with the latest version 2.7.10 :( I really hope this will be fixed soon with all the other bugs (avatars are broken, file transfers are broken, custom icons are broken etc) :(

comment:22 Changed 5 years ago by glittalogik

Same issue adding a yahoo.com.au buddy in MSN with 2.7.11

comment:23 Changed 5 years ago by claber

since this is a long standing issue nobody seems to be able to fix, can you please at least stop the message boxes from popping up every single time the user logs in the MSN network? It is rather annoying that every time I launch pidgin, or when my notebook briefly loses the connection to the internet, I get 3 popups from pidgin complaining that it cannot add some MSN user that happens to have a @yahoo.* address. http://imgkk.com/i/cv9i.png Thanks

comment:24 Changed 4 years ago by sekkel

I totally second the removal of fucking annoying popup window. everytime i lose the connection to the wireless even just for a second brings up that fucking popup.

Changed 4 years ago by davidmarshall15

Error when connection to MSN with a username like "username@…"... Yes my Microsoft MSN username does end with yahoo.co.uk!

comment:25 Changed 4 years ago by davidmarshall15

Attached another example of this issue.

I used pidgin around 4 years ago, thought it was great on Fedora until an error box popped up every time I logged in, so on Limux I simply switched to another of the many clients available.

4 year later, today I try pidgin again and get the same error message on Windows 7 (attached above), now I remember why I stopped using this IM client.

The summary of this issue is:

  • Error when connection to MSN with a username like "username@yahoo.co.uk". Yes my Microsoft MSN username does end with yahoo.co.uk!
  • It only happens with pidgin
  • I have experienced it on Windows and Linux

So I will not be using pidgin, but please consider I have taken the time to register and post this update for the devs on my way out.

I sincerely hope it is fixed soon for others and at least before I forget about the issue and try again in 2016!

comment:26 Changed 3 years ago by Zian

I'm still getting this error with version 2.10.7 of Pidgin. My error message says:

Unknown error (204): <ml><dn="yahoo.com"><c n="omitted" l="3" t="32" /></d></ml>

comment:27 Changed 3 years ago by mmatos

To anyone having this issue: it has to do with an MSN (Live) contact that Pidgin does not correctly handle. A workaround for this issue is as follows:

  1. Determine which of your MSN/Live accounts is the culprit. You can do this by going to Accounts > Manage Accounts and disabling ALL of your accounts. Enable them one by one (and wait at least 30 secs) until you get the popup.
  2. Go to http://www.live.com/ and log in to that account.
  3. Use the top left menu to navigate to "People"
  4. Look through your contacts and find any that seem to have no information. (No name, etc.) They may be at the very bottom of the list (uncategorized).
  5. Delete those contacts.

Next time you log in the issue should be gone.

This IS a bug in the Pidgin client but it's probably something that affects very few people and is hard to troubleshoot. Unfortunately I have been unable to find a way to replicate it, although I believe the issue stems from malformed contacts that may have been added by a third party client (pidgin, trillian, etc).

If I find some time in the near future I'll see if I can dig through the code and come up with a patch. This bug has been open for way too long.

comment:28 Changed 3 years ago by madpoet

Even removing from the live.com account is not working, I'm still getting that annoying message :(

I'd suggest removing the "alert" message and log it instead... Or view in some notification area if you have that chance instead of using an alert box because the annoying part is we have to click "ok" every single time! And it flashes in the taskbar too till we click ok...

Putting some "Don't show again" or "Don't show again for this user" checkbox is another option...

comment:29 Changed 3 years ago by anothertrad

I have this problem on Adium which also uses libpurple and I knew I would find some pidgin discussion about it. So maybe is not fair to say it's a problem located at the pidgin (or adium) client but on libpurple (unless it's expected to throw this error. but what is the event? adding a contact or the contact is already added, and "adding" in this case means just showing on the buddy list?) I also removed all unnamed contacts in my live account, didnt work.

comment:30 follow-up: Changed 3 years ago by doublehp

MSN was closed months ago. Don't you ever read your emails ? Microsoft sent an warning email to every single MSN user to warn about Live-Skype fusion.

Regarding Pidgin, all bugs related to MSN should be closed-WONTFIX. Cause proto died.

Unless there is at last a Skype plugin project ? been said since over 10y that Skype would never be supported by main trunk of Gaim; and Gaim-VV never worked for me.

comment:31 in reply to: ↑ 30 Changed 3 years ago by anothertrad

Replying to doublehp:

MSN was closed months ago. Don't you ever read your emails ? Microsoft sent an warning email to every single MSN user to warn about Live-Skype fusion.

of course I know about it. Yes I read my emails. Are you on this trac to help or be pointlessly rude? In addition, if I have name @ otherdomian.com as my live account means I don't care about their emails, only the use of chat services.

Regarding Pidgin, all bugs related to MSN should be closed-WONTFIX. Cause proto died.

Then why libpurple, pidgin and adium still supports msn/live accounts? Also why MSN chat services are still operational, everyone being able to log in and all.

Unless there is at last a Skype plugin project ? been said since over 10y that Skype would never be supported by main trunk of Gaim; and Gaim-VV never worked for me.

Last edited 3 years ago by anothertrad (previous) (diff)

comment:32 Changed 3 years ago by rekkanoryo

There is a well-known target date for the death of the MSN protocol. I do not recall it at the moment, but the protocol's days are numbered. If someone feels like fixing the bugs before then, they're welcome to do so, but I don't see it happening. Once the protocol is officially dead, we will close all MSN related tickets and remove the protocol from our source.

comment:33 Changed 5 months ago by dx

  • Resolution set to out of date
  • Status changed from new to closed

This feature (yahoo contact support) doesn't exist anymore in current skype clients

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!