Opened 10 years ago

Closed 10 years ago

#9021 closed defect

Cannot Add User, Unknown Error 241

Reported by: M Owned by: khc
Milestone: Component: MSN
Version: 2.5.5 Keywords:
Cc:

Description (last modified by khc)

When I log in, I get Cannot add user, Unknown error 241.

From what I understand, I have two contacts who throw up a different number then the rest of my contacts.

Debug log:

Sending adl with payload: <ml l='1'><d n='hotmail.com'><c n='AN E-MAIL THAT GIVES ME THE ADL ERROR' l='7' t='1'/><c n='ANOTHER E-MAIL THAT GIVES ME THE ERROR' l='7' t='1'/><c n='DOESN'T' l='3' t='1'/><c n='DOESN'T' l='3' t='1'/><c n='DOESN'T' l='3' t='1'/><c n='DOESN'T' l='3' t='1'/><c n='DOESN'T' l='3' t='1'/><c n='DOESN'T' l='3' t='1'/><c n='DOESN'T' l='3' t='1'/><c n='DOESN'T' l='3' t='1'/><c n='DOESN'T' l='3' t='1'/></d><d n='live.com'><c n='DOESN'T' l='3' t='1'/></d></ml>

These two contacts also are both blocked, which I think is also what's attributing to it. When I unblock them, I get a SOAP fault:

Debug log:

msn: Operation {} Failed, SOAP Fault was: <soap:Fault><faultcode>soap:Client</faultcode><faultstring>Member does not exist </faultstring><faultactor>http://www.msn.com/webservices/AddressBook/DeleteMember</faultactor><detail><errorcode xmlns='http://www.msn.com/webservices/AddressBook'>MemberDoesNotExist</errorcode><errorstring xmlns='http://www.msn.com/webservices/AddressBook'>Member does not exist </errorstring><machineName xmlns='http://www.msn.com/webservices/AddressBook'>BY2ABCHWB315</machineName><additionalDetails><originalExceptionErrorMessage>BAYABCHSQLA510.ABCHA5100524..prc_ABRoleMappingDeleteInt_W12R1:  Member Does Not Exist in specified Role(s) : RoleMap Delete - 2
BAYABCHSQLA510.ABCHA5100524..prc_ABRoleMappingDelete_W12R1:  Failed to execute stored procedure prc_ABRoleMappingDeleteInt.</originalExceptionErrorMessage></additionalDetails></detail></soap:Fault>

I've downloaded the actual Windows Live Messenger ( I run Windows ), and I've tried going into Tools -> Options -> Privacy and seeing if I had duplicate accounts, and I didn't. I unblocked, blocked, and then unblocked the two contacts AGAIN. and I still got the error. (ADL error in the debug log) I've gone through the website and searched anything having to do about an ADL error, and Unknown Error 241.

I think if we find out as to why the two accounts that are responsible for this error are sending the adl with the payload l='7' then maybe we'd be able to fix this. This WAS set to be fixed on 2.5.5, but I believe the ticket(s) got automatically shut down by the system, there was another ticket but it was set for "worksforme"

Change History (16)

comment:1 Changed 10 years ago by mgl

I have this same problem. I happened to me today after I used the MS client, and setup a MS Live network account. While messing around with the MS Live account settings, I used a tool that merged duplicate contact entries. When I next returned to the Pidgin client, I started getting this error.

I'm fairly sure it is a problem with the contacts after I used the merging tool, but I can't figure out which individual contact is causing the problem. I've removed a bunch of blocks in the MS Client. I've also deleted/recreated the MSN account in Pidgin, but the error is still there.

Is there anything I can do to help figure this out?

comment:2 Changed 10 years ago by mgl

Ok, I've found one user on my account that appears blocked every time I login to Pidgin. The same user is not blocked when I login to the MSN client...if I block/unblock that user, it has no effect on their blocked state in Pidgin. If I unblock that user in Pidgin, it'll be blocked again next time I login.

That, plus I'm still getting the unknown error 241.

comment:3 Changed 10 years ago by khc

  • Component changed from unclassified to MSN
  • Description modified (diff)
  • Owner changed from lschiere to khc

comment:4 Changed 10 years ago by khc

  • Description modified (diff)

comment:5 Changed 10 years ago by Castle

  1. Download aMSN Portable from http://portableapps.com/apps/internet/amsn_portable
  2. Turn on the MSN account that is having the error
  3. Go to Account then Preferences
  4. Go to "Privacy"
  5. Click the user(s) that are causing the error
  6. hit "Add to AL" and "Add to FL" for the user(s) that are causing the error
  7. Problem solved.

Side note - How do I know which buddy is causing the issue?

  1. Open up the debug window from "Help" in Pidgin
  2. Log off your MSN account
  3. Log back in
  4. Check to see if any account gives the ADL a payload OTHER than l='3' t='1'

Thank you, have a nice day.

comment:6 Changed 10 years ago by Castle

The error is being caused because Pidgin doesn't SEE them on the server. I have no idea why. The ADL is coming up with 7, instead of the normal 3. I've completely wiped out my entire .purple folder to fix this issue before, and it still happened. So it IS a server issue. Do what I've said above, and you won't get the error :D

comment:7 Changed 10 years ago by mgl

I have several users who show up with ADL payloads other than l='3' t='1' - some of them have l='4' or l='2'. If I try the Add to AL / Add to FL thing in aMSN, I get "Error connecting to server: invalid parameter".

However, I'm guessing that maybe the problem is there are several users showing up in the ADL payload that actually do not exist anywhere in the privacy settings in aMSN. They're old/dead accounts that I have deleted before. But how do I clear those out? There is also one other non-existent user that shows up all by itself in a second separate ADL payload.

comment:8 Changed 10 years ago by Castle

mgl: Do you know the user(s) who cause you the problem?

( Please don't post the screen names of the users, I'm just asking if you know which buddies are causing it )

If you know, will you post what it says in the debug log in the ADL payload section?

comment:9 Changed 10 years ago by mgl

Here's what I've got when I filter the debug window for 'ADL', with user/host names replaced with 'xxx':

(17:39:29) msn: Sending ADL with payload: <ml l='1'><d n='xxx'><c n='xxx' l='4' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/><c n='xxx' l='3' t='1'/></d><d n='xxx'><c n='xxx' l='7' t='1'/></d><d n='xxx'><c n='xxx' l='2' t='1'/></d><d n='xxx'><c n='xxx' l='3' t='1'/></d><d n='xxx'><c n='xxx' l='2' t='32'/></d><d n='xxx'><c n='xxx' l='3' t='1'/></d><d n='xxx'><c n='xxx' l='3' t='1'/></d><d n='xxx'><c n='xxx' l='3' t='1'/></d></ml> (17:39:29) msn: C: NS 000: ADL 9 1656 (17:39:29) msn: ADL error (17:39:29) msn: S: NS 000: ADL 9 OK (17:39:29) msn: Sending ADL with payload: <ml l='1'><d n='xxx'><c n='xxx' l='3' t='1'/></d></ml> (17:39:29) msn: C: NS 000: ADL 15 75 (17:39:30) msn: S: NS 000: ADL 15 OK

comment:10 Changed 10 years ago by Castle

mgl: I would recommend doing the above with aMSN on the user who gives you l='7'

If that doesn't work, try it on any that are still on your buddy list that DON'T give you a l='3'

I hope that helps.

comment:11 Changed 10 years ago by mgl

Any time I clicked 'Add to FL' or 'Add to AL' I'd get that error I mentioned. So I used the move, delete/copy buttons. I've deleted, block, unblocked, added, removed...and no matter what I do, this particular user keeps returning when I start Pidgin.

Pidgin is the only IM client that seems to have a problem with it, and I'm out of ideas.

comment:12 Changed 10 years ago by Castle

mgl: Did you click the user, then attempt to add them to FL and AL? or did you just click the button(s)?

I don't understand why this would work for me, and not you.

comment:13 Changed 10 years ago by mgl

Yes...the user usually appeared in all three lists. If I deleted them, it would reappear in one of them (RL I think). In any case, I tried selecting each one before clicking the FL/AL buttons...same error in all attempts no matter what.

I think the problem has to do with the live.com tool for cleaning-up duplicate addresses in my contacts list. The same user that's giving me problems now is one of the ones who would have had multiple addresses.

comment:14 Changed 10 years ago by QuLogic

  • Status changed from new to pending

Is this any better in 2.5.6? It should automatically assume buddies in both AL and BL are only in the BL so that the server doesn't complain.

comment:15 Changed 10 years ago by mgl

The error message doesn't pop-up, so I guess that part is fixed. However, one of my contacts keeps showing up as blocked in Pidgin, despite not being so in other clients.

comment:16 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!