Opened 10 years ago

Last modified 6 months ago

#9046 new defect

Auto-away sets away message...

Reported by: Daemonax Owned by: deryni
Milestone: Component: pidgin (gtk)
Version: 2.5.5 Keywords: Auto away
Cc: Dawudd, gjmf, sambrightman, mwoodling, NathanHind

Description

This annoying behaviour has been around for many versions.

Using version 2.5.5 on Ubuntu 9.04

Auto-away is set to change status to away. When it does this though it automagically creates the message "I'm not here right now" rather than simply setting itself to away.

I think it would be best for this behaviour to be simply removed, and away messages to only be ones that are intentionally created by the user.

Change History (43)

comment:1 Changed 10 years ago by QuLogic

  • Resolution set to worksforme
  • Status changed from new to closed

Instead of using the built-in "Away" status, you need to use one of your own saved statuses for the "Change status to" option.

comment:2 Changed 10 years ago by Daemonax

That is not a resolution to this problem... That is simply a work around rather than really fixing it.

You're just saying "Eh create a customer status and use that instead".. I should be able to choose away, and have it set itself simply to away. The program is not behaving as one could reasonably expect.

comment:3 Changed 10 years ago by resiak

  • Resolution worksforme deleted
  • Status changed from closed to new

I can see two reasonable behaviours for auto-away:

  • Use the same message that was previously set (which is what Daemonax is after); or
  • Use a particular custom status.

In the former case, you always want to be Away, not some other status type. So I think a reasonable UI could look like:

(o) Use the current message
( ) Use a saved status: [I'm not here right now | v]

comment:4 Changed 10 years ago by resiak

It could even subsume the [x] Change status when idle tickybox.

When idle:
( ) Don't change my status
(o) Change my status to Away
( ) Use a saved status: [I'm not here right now | v]

comment:5 Changed 10 years ago by deryni

The issue here is somewhat simpler than that actually, the request (as far as I understand it) is simply to have the default Away status work like the other default statuses and not use a message (as best I can tell without testing none of the other defaults have a default message).

This request has come up previously (possibly in another ticket, though I'm not sure). The issue is that the user cannot override the default message without creating a custom Away status, and until it is used does not even know that a default message will be used.

If we currently use the previously set message (to mimic what the status selector does) I personally think that's a bug, and doubt that anyone expects it to work that way so I think we should fix that and set the default statuses to not have default messages. I would be ok with a special default Away+message status which only appears in the Preferences window to keep the current behaviour.

comment:6 Changed 10 years ago by ilgaspa

I think that the correct behaviour should be:

  • If away status is set to simply "Away", Pidgin should switch to away keeping current status message, like for example MSN does
  • If away status is set to a saved status, Pidgin should switch do away (or other specied away status) and used the saved status status message. If the slected saved status has an empty status message, the empty status message overrides the currently set status for the away time

I find the current pidgin behaviour (wich overrides my current status with "I'm not here right now" regardless of the status message set) plain wrong... There's no way to tell it to simple switch to away leaving the status message untouched at the moment. We can simulate this behaviour by saving an away status with the same message as the available status message we use, but it's a workaround, not a solution.

This seems a trivial issue to solve, noone wish to take care of this bug?

comment:7 Changed 10 years ago by deryni

  • Owner set to deryni

comment:8 Changed 9 years ago by gjmf

I'd really, really like to see this behaviour improved. In our environment, one of the most common complaints about Pidgin is that, for whatever reason, folks still have their status set to "I'm not here right now" even after they've come back to the computer. Much better if the status text is never changed in the first place.

comment:9 Changed 9 years ago by jerkface

Agreed. I am dumping pidgin due to this behavior. Who actually thought it was reasonable?

comment:10 Changed 9 years ago by deryni

You are dumping pidgin because the default Away status has a message? When you can easily create your own away status without such a message and use it?

The issue here is that we do not make it immediately clear that such a message will be used and do not allow people to prevent that message from being used with the default status. A fact to consider here is that pidgin has had that default Away message since essentially forever (if not in fact actually forever) so considering that the complaints about it have just now started really happening in earnest (fairly long after the initial change to the new status system even, the new status system is what has exacerbated the issue) indicates that the issue is likely not nearly as serious as one might want to make out. I am not making light of the problem, nor attempting to indicate it isn't a problem, just trying to put it in the proper perspective.

There is an additional wrinkle, as indicated by ilgaspa, in that some people would like the default statuses to preserve their current message when they have one, which is likely an expectation derived from MSN's historic lack of status messages (only friendly names) but is a usage we have been trying to better serve recently.

I am currently unable to come up with an appropriate way to model this without simply adding a checkbox to the preferences dialog page dealing with the auto-away status which says "Preserve current status message over auto-away" or similar, which is by far not an ideal interface for this.

There is one alternative, which is somewhat more complicated to use, which would be to create that checkbox in the New Status dialog and require people to create their own auto-away status to do this sort of thing.

comment:11 Changed 9 years ago by mwoodling

I am using 2.6.2 on Ubuntu 9.10. This is irritating behavior for me and 2 other users at my company that are relatively new to Pidgin (new within the last couple of months). When Pidgin is open and we don't use it for a while, status changes to "Away" and the message is "I'm not here right now". Then, when I manually change the status to "Available", the message is still "I'm not here right now". Other users then see me as a green dot with "I'm not here right now". I have to delete the text in the message to make it go away. This makes no sense at all and I don't understand why anyone would want this behavior.

comment:12 Changed 9 years ago by deryni

The reason we keep the message in the entry box (which I'm not sure I realized took place when manually switching back from the auto-away status) is because there are many people (largely MSN users) who want this behaviour for status messages they have entered for themselves.

Your problem is that you aren't hitting backspace or delete after you change that status to clear the message. Which, I mentioned before, is far from a critical problem. If you interact with pidgin, thus causing it to bring you back on its own it will likely (I say likely because without testing I cannot be sure) remove the message correctly, that is I believe it is your manual interaction that is causing the problem.

If this problem is really that horrible to you you can (as I indicated in my previous comment) simply create an Away status without a message and set that as the status to use when going auto-away or disable auto-away if you don't want that feature at all. Either solution avoids this problem *entirely* and takes less time than the time it took you to decide to look up this issue and file your comment.

Again, I do think our default status needs to better indicate that it has a message and I believe we should likely have a default Away status that doesn't have a message and I further believe that a way to have a status (auto-away or otherwise) not set a message (thus using the current message) is a good idea (just one that needs a good interface designed before it should be done).

comment:13 Changed 9 years ago by sambrightman

I experience this regularly and only manually set away/available rarely. Whilst I agree that it's not a show stopper it does look silly and without fail confuses friends. It seems there should be a relatively simple solution that works in all cases: for example, auto-away replaces existing status, cancellation of away restores old status. MSN users would either not set auto-away text or would set it, but would get their old status back after.

comment:14 Changed 9 years ago by gjmf

deryni:

The problem with your logic is the fact that my end-users never, ever manually typed in "I'm not here right now." It was automatically set when they stepped away from their computer.

As I wrote before, this strange behaviour ("I'm not here right now" text automatically added, and retained even with green/available status) is the #1 complaint I hear when trying to move my clients' staff to Pidgin from proprietary IM tools. It's really surprising to me that there's such strong resistance on the part of the developers to making this behave more intuitively.

comment:15 Changed 9 years ago by mwoodling

Exactly, deryni! I never once typed in that text. In fact, after it appeared the first time, I exited Pidgin, edited out the text in status.xml, started Pidgin and the "I'm not here right now" status appeared again. Where did it come from if I never typed it in? Did it come from one of the online services? Is it in Pidgin's code? How could I NOT be surprised that it shows up?

Anyway, I don't want to keep getting worked up over an IM client, so I'll shut up now.

comment:16 Changed 9 years ago by gjmf

So, I'll put my money where my mouth is (er, fingers are). :)

Cernio Tech Co-op (www.cernio.com) will pay a $50 bounty for resolving this issue.

Conditions:

  • Cernio Tech Co-op's support must be acknowledged publicly by the Pidgin project, on the www.pidgin.im web site and/or the public Changelog.
  • Payable via Paypal or Google Checkout in US Dollars or Canadian Dollars, as per the recipient's choice
  • Payable to the Pidgin project or to the individual Pidgin developer who implements this resolution, as per the consensus in the comment thread on Pidgin Trac ticket #9046.
  • Payable within 7 calendar days of a public release of a stable version of Pidgin for Windows whose Jabber/XMPP and Google Talk behaviour does not automatically insert any status text in any circumstance, unless the end-user has typed in that status text.
  • Bounty offer expires on 1st June 2010.

My clients' staff look forward to not having to explain to their bosses why they're "Not here right now" all the time. :)

Graham Freeman General Manager Cernio Tech Co-op www.cernio.com +1 415 462 2991 office graham.freeman@… (Email/Jabber?/SIP)

comment:17 Changed 9 years ago by deryni

sambrightman: You have this happen even when pidgin handles returning you from the auto-away status itself?

Yes, the auto-away status should be enabled and disabled cleanly (at the very least if pidgin handles it on its own, if the user manually comes back we can't automatically clear the message because they may not want that).

If pidgin is not cleanly removing the message when it unsets the auto-away status that is a bug and should be fixed.

gjmf: You seem to have misunderstood my point. My point is that having the default Away status have a message is not in-and-of-itself a problem. The problem is that the message is not discoverable until it has been used the first time, that one cannot (without creating it manually) have an auto-away status of Away without a message, and that there may be a bug whereby pidgin is "leaking" this default text to the 'returned from auto-away' status.

There is absolutely no resistance to fixing any of the actual issues, the issue is that I'm not sure we know what all the actual issues are.

mwoodling: It is built-in default text for the Away status in pidgin. I am only surprised that people are surpised by it because it has (quite literally) been in the pidgin source as the default text for the default Away status for a decade (and the current "problem" of it being largely undiscoverable has been unchanged since the pidgin 2.0.0 betas were released in 2006-2007). I'm not at all surprised that having a largely undiscoverable message surprises people.

I would also like to re-iterate that I really am entirely amazed at the strength of the reaction to an issue that is entirely (and simply) avoidable. (I am not in any way trying to invalidate the annoyance I am just truly astonished at how deeply it seems to have affected people.)

gjmf: Do either of my proposed solutions satisfy your criteria? (I'm not fishing for the bounty, and wouldn't claim it even if I did it, I'm just trying to understand what exactly you want and whether my solutions qualify.) Namely that there either be a default "Away with no message" as well as the current "Away with the historic default message" statuses and/or that pidgin create an "Away with historic default message" status by default and (again by default) set that as the status to use for auto-away? (Also, are you really unable to just create the Away status with no message for the staff and be done with this?)

comment:18 Changed 9 years ago by gjmf

Hi, deryni,

Thanks for the response.

The crystal-clear message I've been getting from my clients' end-users is that any pre-set "Away" text is definitely in and of itself a problem. And, beyond that, it's a serious problem when that "Away" text persists after they're no longer away, such that the status is green but the text says "I'm not here right now".

This counterintuitive behaviour keeps causing misunderstandings amongst the teams using Pidgin, and after the misunderstandings are cleared up (e.g. people learn to ignore the status text and look at the status color instead) then I get more push-back over my recommendation to switch to Pidgin (and Jabber/XMPP) away from the proprietary AIM client. (Yep, I know the proprietary AIM client is awful. But it's an awfulness that these people are used to.) I then have to waste my time re-explaining why we switched, and why it's still worth it even when this kind of thing happens. I can't bill for that time, my client feels that their time is being wasted, and Pidgin loses the opportunity to make its way on to the personal computers of each of these staff. Nobody wins.

Yep, I'm sure that these people *can* manually change the text. They could also change any number of the rest of the 10,000 options available to them on their computers. But they're overworked as it is, and they really don't want to spend their time trying to figure out the configuration on programs whose purpose they barely understand to begin with - the vast majority of these people are experts in other things besides computers - nor do their employers want to pay me or my staff to go to each computer and change the settings on each Windows login profile.

So, to reiterate, the people using Pidgin in my world see any auto-set text as a problem, and auto-set text persisting when it shouldn't as a worse problem.

With that said, *thank you* for your work on Pidgin. It's great o have an open-source standards-compliant cross-platform IM client.

comment:19 Changed 9 years ago by sambrightman

I so rarely manually set away that I'm confident this happens all-auto.

I don't think there is a problem with default text, in fact I quite like it. I think the problem is how it's handled: can anyone explain a use-case that my solution does not account for?

comment:20 Changed 9 years ago by deryni

sambrightman: The issue would be with your manually setting the "return" status not the away status. That is, you leave your computer idle long enough for pidgin to set you auto-away (with the default global Away status which has the default message) and then when you return to your computer you *do not* wait long enough (or pidgin is set to use "From last message sent" idleness and you do not send a message) for pidgin to automatically set you back to your pre-auto-away status (that is you manually switch the status in the buddy list status selector. If *that* is happening that is a bug that needs fixing.

gjmf: Thanks for more clearly explaining the situation you are seeing, it helps understand things somewhat. Unfortunately you didn't really answer my question about whether my proposed solution is acceptable or not? If the workaround for this problem involved switching from a built-in saved status (Away with message) to the built-in global status (Away with no message) would that be enough? Or is even that too much work? (Again, assuming there is no message leaking since leaking is a bug.)

My "concern" about simply removing the message entirely (aside from it having been in pidgin for ages) is that if people are expecting it to be there when it disappears we will have as many angry users (if not more) than we have now (and they will have the equivalent workaround available to them as the users here do but they will need to remember/find/re-input the default text as opposed to simply entering no text).

comment:21 Changed 9 years ago by sambrightman

I don't use "from last message sent" and not exactly sure what you mean by "wait long enough"... It appears to be a bug to me from what you say, but I'm not sure I totaly understand the delay thing, and can't reliably reproduce.

Once again, I am not clear how my proposal to always "pop" the previous status when cancelling away fails to solve all problems for all people - I believe it does.

I am also against removing the default if it can be avoided because it's useful for me and - as you say - has a long history. Changing a preference for one group only works against another group.

comment:22 Changed 9 years ago by deryni

When you leave pidgin idle, it will eventually set your status to whichever status you have set to auto-away. When you return it is supposed to then unset the auto-away status and restore whatever status you had previously.

By "wait long enough" I meant it can occasionally take pidgin a few moments to respond to the notification it receives indicating that the user has returned and during that time you can (if you act quickly enough) manually unset the auto-away status rather than letting pidgin handle that itself. If the message leaking only occurs when the user manually unsets the auto-away status then that is potentially not a bug but rather simply the way the status selector works (though it may in fact be both a bug and working as designed, it all depends on what exactly the user is doing and what exactly is happening).

As to your suggestion, simply always removing the message when switching statuses is not a solution (pidgin used to do that) because it breaks the model of status messages people coming from MSN are used to (namely that the message and the status are unrelated fields/concepts/etc.). It is exactly because we were trying to handle that model better that the status selector in the buddy list retains the existing message when the status is switched (and selects it all to facilitate deleting or changing it for people for whom it should not stay).

So again, the questions here are:

  • whether when the auto-away status has been activated and de-activated by pidgin itself the status message is leaking
  • whether when the auto-away status has been activated by pidgin and de-activated by the user (via the tray icon or similar mechanism) the status message is leaking
  • whether when the auto-away status has been activated by pidgin and de-activated by the user (via the buddy list status selector) the status message is staying (I say staying and not leaking because I think having the message stay here may in fact be correct given the way the status selector is designed to function. This would be an unfortunate collision of features but not exactly a bug.)

comment:23 Changed 9 years ago by sambrightman

On the issue of potential bug: I believe the status is leaking. I very rarely change the status myself, and frequently see my status (via friend saying "what the hell?") as "available - i'm not here right now". No amount of waiting for pidgin will change that. It's hard to confirm this 100% though, as it's still not an everyday event. I'll try to pay more attention when it next happens.

There still seems to be some confusion; once again, my proposal: Pidgin pushes the current status when setting auto-away and pops it when cancelling auto-away. I believe that this solves the problem for MSN users as well as gjmf (besides the wording... not sure I understand why that's an issue). Manually cancelling away would also pop the previous status, unless the manual cancel specifically chose a different one... I might have missed something, but intuitively the obvious general policy is to separate the auto-ness from the user's intention.

comment:24 Changed 9 years ago by leorolla

Hi all,

My penny:

It is not natural to set the user message when the user merely selected "change status".

This is a bug. Many possible fixes, but no matter what, as it is right now, this is a bug.

I install software in English, but I speak other languages rather than Englisth with alsmost all my msn/gtalk/icq contacts, and the message en English even sounds ackward. I did not choose that message, I did not check on any box telling Pidgin to set messages for me, so it is a bug.

I'm new here, don't know what 'pending' means, if it is pending more information from the person who reported it or if it is pending a solution from the developers.

comment:25 Changed 9 years ago by gjmf

My eyes gloss over when this gets too detailed - sorry - so I'll just summarize:

The persistent, consistent negative feedback about Pidgin that I get from my end-users is centered around the status text behaviour.

People prefer not to have status text set automatically.

They don't mind auto-away being set by default; nor do they mind having status text as an option - but they don't want text pre-populated.

People HATE having Green/Available? status and "I'm not here right now" (or equivalent) status text. It makes them look unprofessional, and makes them ask me to uninstall Pidgin. I don't want to do that, 'cuz I'm trying to migrate my clients over to standardized Jabber/XMPP services instead of proprietary services.

Thanks again for your volunteer time on this free, open-source program that by and large works well.

comment:26 Changed 9 years ago by gk

Another annoying thing about this default behaviour occurs when using Pidgin to connect to Facebook Chat. I have the "Set facebook status through Pidgin status" option set and keep ending up with a Facebook status of "I'm not here right now". Looks really silly!

comment:27 Changed 9 years ago by sambrightman

One thought on the potential real bug: if Pidgin crashes/is killed and is set to auto-restore previous status, this could maybe lead to keeping the old auto-away status? Maybe that has happened to me. I haven't seen it happen recently after a couple of more stable releases. I think it probably is a bug if true: auto-away would be cancelled when you return to computer, and clearly you are returned if you have to restart the program, so the auto-away should be cancelled.

I also agree that the Facebook status idiom is slightly different and potentially a special case.

I think that allowing the auto-away text to be directly edited in prefs (creating a new status?) is a valid RFE, but it's not up to me. I would probably push for it if I had any influence. But on the actual issue of the auto-away text existing, I have little sympathy. It's not "clearly" a bug, it's not anything but subtlely different from just being "away" in a professional environment, and installing and English trying to justify disliking it because it's in English is just weird. You *can* configure it to be different, and it's easy to do so. Possibly could be easier.

comment:28 Changed 9 years ago by leorolla

I think I didn't express correctly, sorry it sounded too particular to my case.

(In my particular case, I say it is ackward that my contacs see this message. When I installed pidgin I chose the language in which I expected pidgin to estabililsh an interface with me, not the language I expected pidgin to show messages to my contacts.)

The fact is: Pidgin has set messages for the user, pidgin did not ask the user whether they wanted it, pidgin didn't even tell the user about that.

If the message sounds akward or not, that is personal, indeed. But Messaging really is personal, right? And the final result is that the user's contacts see a message coming from the user, a message that was never set by that user.

A software that works as a messager client is setting textual messages on the behalf of the user without any action from the same user (what we call default behavior), that is preety bad.

Not being a typical programming-issue bug (like security or consistency or robustness or syncrhonization), but rather a simple easy-to-fix misbehavior, doesn't mean it is not a Real Bug.

Thanks for developping good-quality free software. Pidgin is great.

I just want to stress that users coming from different backgrounds can be bothered by this missbehavior in a way that may or may not make sense for us.

comment:29 Changed 9 years ago by sambrightman

Good to clarify. But the fact remains that all software does plenty of things the user didn't explicitly ask for. There is nothing insecure, insidious or distasteful about this behaviour in general, just that some people don't like it. It's not leaking personal data or taking over the computer, and it's not a repeat annoyance. Auto-away is pretty standard behaviour that one would expect from IM clients, setting it as default, and the status that accompanies it is a matter of preference, not control over one's computer. And it's in the preferences.

I'm completely disinterested in whether it actually happens or not, but I respect the need not to tinker every preference to every interest group. If there's a solution that doesn't amount to "do it my way because i prefer it", that would be more constructive.

And there is always an element of language leaking through to the other user: after all, the available and away statuses are themselves in English, aren't they? It seems a very very particular corner case, and there is an existing, simple solution.

comment:30 Changed 9 years ago by Daemonax

There is a very simple fix.

You simply don't have automatically set messages, and allow people to create and set their own custom messages using the already existing "new status" option... It is really very simple. And if people want to be able to quickly type an away message, then you could have in the status menu "enter custom message" which would allow you to just quickly type in a custom status, it could just stick with the current status.

Or each status could have a little "+" addition button next to it that allowed you to select a status icon and set a custom message for it.

It's the automatic default message that gets in the way and causes issues for people. Just remove it.

Personally, I don't know anyone that uses the text entry box that pops up, it just causes irritation it seems.

comment:31 Changed 9 years ago by sambrightman

That sounds and awful lot like "people who want the status quo should have to do what I'm unwilling to". Unless I've misunderstood it akso sounds like you want to add UI for changing the message whilst removing the UI that lets you change the message.

comment:32 Changed 9 years ago by leorolla

Solution:

Very simple, 10 minute, urgent solution: replace "I'm not here right now" in the source code by "". It would be great to have this solution while one figures out all possible issues related to auto-away messages.

sambrightman:

No, the status Available, Away etc are *not* in English. They are in Green|Red|Blue|Gray/Offline?, in Disponível|Ocupado|Ausente|Desconectado , or in any other implementation of this standard by your contacts' messenger client. There is a whole world outside. If you borrow the computer from a french friend and suddenly all your contacts see "Je suis momentanement indisponible" they will certainly find it funny, silly, awful, unproffessional etc.

I know auto-away is pretty standard behaviour and I love it, but although the status that accompanies it is a matter of preference, it is not standard. Even if the bulk of the users think "I'm not here right now" is OK, if there is a tiny minority that has problems with it, better choose the "don't put words in my mouth" solution.

The point is not "do it my way because i prefer it", it is "do not show idiomatic text to my contacts as if it were typed by myself". I know all software does plenty of things the user didn't explicitly ask for, but this about a principle. Appart from self-publicity, it is not that different from e-mails that are signed "sent from my iPhone". I agree it is not the same as leaking sensitive private information, but it can be awful. I could try to describe a thousand situations where the user is bothered about these messages, but *that* would be wierd. Just be creative and try to imagine it. One of the best things about free software is to stimulate people's creativity, although it often ends up stimulating reductionism.

comment:33 Changed 9 years ago by sambrightman

Continually repeating that the "fix" is simple: it's pretty obvious to everyone that changing it is simple, but your viewpoint is predicated on it being an issue in the first place. Repeating how simple it is feels like belittling the developers, and isn't going to help. So try making clear, general points that stand up to criticism from people who *aren't you*. Some people like this behaviour, remember?

I just installed the Portuguese version of Pidgin (there are some UI issues here too: installer implies language might only be for installer, and localisation is not complete) and it sets the status in Portuguese. I don't think the language criticism is in-and-of itself a problem. You have to expect when installing a product in a certain language that some of that language will be seen by your friends/colleagues. If I was communicating with someone in France, I would not be either surprised or annoyed to see some French status or so, and that would apply to other types of program too. For example, I often see German/French/Portuguese? email text for quotations/forwards.

The idea that the text currently reads as if written by the user is more valid criticism, I take that point. I'm not sure I would call it "awful" and enough to gain a minority their change (if indeed it is a minority, but deryni suggests so). Again, it is not uncommon to see idiomatic text, such as in emails (the iPhone text is annoying, but the more pertinent example is "on x/y/z p wrote:" which usually has a default, is localised etc. exactly as Pidgin is). No?

At the least though, the preferences drop-down should show the messages that will be used.

Deryni:

To play advocate: removing the message seems unlikely to cause problems with existing users that like/expect it: they will still be set away. If you think it's better without, just take it out - the biggest non-selfish argument against it is that it's duplicating the "away" information IMO. If certain people really find it world-endingly annoying and are sufficiently non-goal oriented to argue rather than change it, the hassle will only continue.

I am more interested in helping find the "real" bug of sometimes not auto-away cancelling. Should I open a new one even if I have little possibility to reproduce? Also, auto-away sometimes doesn't seem to kick in after the allotted time... had some trouble testing. Is my definition of idle different from Pidgin's?

comment:34 Changed 9 years ago by leorolla

The idea that the text currently reads as if written by the user is more valid criticism, I take that point.

Nice!

I don't want to play the troll, just wanted to stress that it hassles some much more than others.

And the hassle is big enough to justify removing it, no matter small is such minority.

I carry explaining this point because I really think that would improve Pidgin.

For my selfish point of view, I would rather just hack the auto-away status message. It takes 5 seconds of my time (10 times more than what it takes to *install* Pidgin, but OK) and I may have ackward messages again when I forget to do that, but still that would be the best individual solution.

I just installed the Portuguese version of Pidgin (there are some UI issues here too: installer implies language might only be for installer, and localisation is not complete) and it sets the status in Portuguese.

There are several other language issues, but that is not the point.

E-mail quotation is a tiny part of the e-mail that people don't care about and normally not even notice (for the few who pay some attention to it at all, it's even charming to see that someone uses e-mail client in another language). Status message, on the other hand, is just *everything* you tell your contacts before you post the first "Hi, how are you?".

comment:35 Changed 9 years ago by sambrightman

"And the hassle is big enough to justify removing it, no matter small is such minority."

Not really: that's what I'm trying to say. The others clearly don't think it's a hassle, do they? The developers can't be expected to change the software for every minority, no matter the size (*especially* when that minority can easily "fix" it themselves). It's a function of amount of hassle, size of minority, possible alternatives etc. Would you allow one person who was really annoyed by something to have their opinion be more important than the other 99.9999%? The size matters, the perspective matters.

As I keep saying, whilst I'm not necessarily against removing it, it doesn't hassle me in the slightest, and I can't see how it possible could be as big a deal as some make out ("unprofessional"??). Even if there's only one person (me) that sees this as unimportant, it doesn't matter the size of the minority, right? ;) So leave it in! I love this super-cool behaviour! Look, it's simple, all you have to do is not change anything. It doesn't matter who disagrees with me! I want the default to be all black too. There are lots of people who love all black GUIs. And it saves energy. Wasting energy really annoys me and it doesn't fit with our corporate green policy, we'll have to stop using Pidgin in our workplace.

See what I'm trying to say?

comment:36 Changed 9 years ago by leorolla

I understand, but in my view it is not the case here.

We just want to put clear that Pidgin is setting idiomatic text messages on the behalf of the user, a preety non-standard and unexpected behavior for incoming users.

This can't be accepted as a *default behavior* in a messenger client.

The consequences to the user can be many(*). It is easy to fix, but *only* when it happens to the user, he will get disappointed, google around and find that Pidgin has this particularity that can be easly hacked, and then either hack it while remaining disappointed or just drop it.

We are all minority here. The majority uses Live Messenger. We can't form a bulk inside this select group and refuse to understand that setting by default idiomatic text messages on the behalf of the user, without asking what that message should be, without warning the user at all, just because the majority of *present-day* Pidgin users don't find it a hassle.

(*) Let's go to cases then: for many groups of people setting a status message explaining that you are away just sounds weird, and the user who just installed and started using pidgin will have weird messages that never came from his keyboard, for some others it can sound unproffessional, up to the point that people come to this page padging for it and even offering money; for others it might just sound silly; for others it might be ackward; some user may not have at all the habbit of displaying status messages about being or not being available and have this message sound ackward to his contacts; some user may hate the expression "right now"; some user have chosen to set Away by messages sent instead of mouse activity, and even though he is sitting there his boss sees "I'm not here..."; and some users may simply find it not correct that the messenger client chooses a message for them without permission.

comment:37 Changed 9 years ago by sambrightman

deryni: I just came to my computer this morning, having done nothing unusual (left last night, presuming auto-away would be set). I have been using the computer for 5 minutes, haven't touched Pidgin, and it is marked Away - I'm not here right now. Do you want me to submit this as a separate bug?

comment:38 Changed 9 years ago by jerkface

This ticket system blows. How do I unsubscribe from this ticket?

comment:39 Changed 9 years ago by rekkanoryo

Once you have commented on a ticket, it's not possible to be "unsubscribed."

comment:40 Changed 9 years ago by andre

Hi,

This is an issue for me as well. Steps to reproduce:

  1. use the default "Available" status (no message)
  2. wait for the auto-away to kick in and update the status (A message is added: I'm not here right now)
  3. move the mouse. The status is changed back to "Available", with the message "I'm not here right now".

For me, this is a clear message leakage. I started with no message, and I now have a message set. [Nowhere did I change the status manually]

I'm currently using Pidgin 2.6.6 under Ubuntu 10.4

comment:41 Changed 9 years ago by jerkface

Holy crap, stop emailing me on this. I haven't used this piece of shit app in ages!

comment:42 Changed 3 years ago by scuba0

Hi,

This is still re-producible on Pidgin 3.0.0~collab-1+201606240749~ubuntu14.04.1. This is clearly a resilient bug and I'd rather want this than new features. It is a paper-cut bug that has lasted a long time.

Steps to reproduce:

1) Use the default Available status (with any message)

2) Wait for the auto-away and it will update the status to Away and set the message to: I'm not here right now

3) Do any activity at the computer. The status is changed back to Available, with the message: I'm not here right now

comment:43 in reply to: ↑ description Changed 6 months ago by kujaw

Pidgin 2.12.0 @ Ubuntu 16.04 - the issue still exists.

Steps to reproduce:

1) Use the default Available status (with any message)

2) Wait for the auto-away and it will update the status to Away and set the message to: I'm not here right now

3) Do any activity at the computer. The status is changed back to Available, with the message: I'm not here right now

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!