Opened 10 years ago

Closed 10 years ago

#9165 closed defect

Pidgin 2.5.5 won't start

Reported by: nralu Owned by: rekkanoryo
Milestone: Component: unclassified
Version: 2.5.5 Keywords:
Cc:

Description

(gdb) bt
#0  0xb7fd7424 in __kernel_vsyscall ()
#1  0xb75a4680 in raise () from /lib/i686/cmov/libc.so.6
#2  0xb75a7d68 in abort () from /lib/i686/cmov/libc.so.6
#3  0x080c2163 in ?? ()
#4  0x08cd19b0 in ?? ()
#5  0xb76d5560 in ?? () from /lib/i686/cmov/libc.so.6
#6  0x00000000 in ?? ()
(gdb) 

I've just updated my pidgin to the version 2.5.5. I've tried to start it... but it crashed. Hope you'll correct this bug soon couse otherwise i can't use pidgin. :D

Attachments (11)

gdb-pidgin-2009-05-14-5.txt (12.4 KB) - added by bewest 10 years ago.
back trace
gdb-pidgin-2009-05-14-6.txt (31.7 KB) - added by bewest 10 years ago.
what happens when starting with -n, and then selecting help->About
valgrind-pidgin2009-05-14-8185.log (254.0 KB) - added by bewest 10 years ago.
1 of 6
valgrind-pidgin2009-05-14-8192.log (25.0 KB) - added by bewest 10 years ago.
2 of 6
valgrind-pidgin2009-05-14-8198.log (24.9 KB) - added by bewest 10 years ago.
3 of 6
valgrind-pidgin2009-05-14-8202.log (25.0 KB) - added by bewest 10 years ago.
4 of 6
valgrind-pidgin2009-05-14-8226.log (25.0 KB) - added by bewest 10 years ago.
6 of 6
valgrind-pidgin2009-05-14-8222.log (24.9 KB) - added by bewest 10 years ago.
5 of 6
gdb-pidgin-2009-05-14-8.txt (9.5 KB) - added by bewest 10 years ago.
ctr-c produced a backtrace for me.
special.log (23.4 KB) - added by bewest 10 years ago.
looks like something related to requesting dns?
bt-_17.05.2009.txt (3.0 KB) - added by nralu 10 years ago.
The backtrace for my problem, i guess it has something to do with jabber

Download all attachments as: .zip

Change History (29)

comment:1 Changed 10 years ago by rekkanoryo

  • Status changed from new to pending

Please follow the instructions to get a backtrace and attach it to this ticket.

Your backtrace is useless, as it doesn't contain enough debugging symbols. Please install the debug symbols packages for pidgin, libpurple (if applicable on your distribution), GTK+, and glib, and obtain a new backtrace.

Changed 10 years ago by bewest

back trace

comment:2 Changed 10 years ago by bewest

attachment gdb-pidgin-2009-05-14-5.txt is what happens when unchecking all plugins, deleting all accounts except gmail, and starting with -n, and changing the status from offline to available.

Changed 10 years ago by bewest

what happens when starting with -n, and then selecting help->About

comment:3 Changed 10 years ago by bewest

It does not crash if I start as root.

comment:4 Changed 10 years ago by darkrain42

Those both involve SIGTSTP, which means you're hitting Ctrl-Z trying to suspend gdb/pidgin (it may be generated in other circumstances. I don't know). Get a backtrace without that.

comment:5 Changed 10 years ago by bewest

Sorry, you are correct. It does not "crash". It says what's pasted below.

It hangs at this point. I can try attaching valgrind. If I hit ctr-c, pidgin ends and gdb won't give me a backtrace. Any advice? I can try running under valgrind.

After it hangs, the GUI is somewhat responsive ( hover states on buttons ), but eventually I have to force it to die. I'll see if I can get it to crash.

ben@xxx:~$ pidgin -n 2>&1 | tee pidgin.stdout.log 
*** glibc detected *** pidgin: free(): invalid pointer: 0x08f024a0 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb75cf604]
/lib/tls/i686/cmov/libc.so.6(cfree+0x96)[0xb75d15b6]
/usr/lib/libotr.so.2[0xb64b038d]
/lib/libgcrypt.so.11[0xb6c35658]
/lib/libgcrypt.so.11[0xb6c3c875]
/lib/libgcrypt.so.11(gcry_cipher_close+0x1d)[0xb6c33fdd]
/usr/lib/libgnutls.so.26[0xb6cf265d]
/usr/lib/libgnutls.so.26(_gnutls_cipher_deinit+0x43)[0xb6ccdc43]
/usr/lib/libgnutls.so.26(gnutls_deinit+0x11f)[0xb6ce27af]
/usr/lib/libldap_r-2.4.so.2[0xb6e64054]
/usr/lib/liblber-2.4.so.2(ber_sockbuf_remove_io+0x78)[0xb6e28bb8]
/usr/lib/liblber-2.4.so.2(ber_int_sb_destroy+0x4a)[0xb6e28c7a]
/usr/lib/liblber-2.4.so.2(ber_sockbuf_free+0x34)[0xb6e28d24]
/usr/lib/libldap_r-2.4.so.2(ldap_ld_free+0x2ff)[0xb6e45b3f]
/lib/libnss_ldap.so.2[0xb6e74176]
/lib/libnss_ldap.so.2[0xb6e77f9a]
/lib/tls/i686/cmov/libc.so.6(__libc_fork+0x1b6)[0xb75ff996]
/lib/tls/i686/cmov/libpthread.so.0(fork+0x14)[0xb76d2824]
/usr/lib/libglib-2.0.so.0[0xb782c385]
/usr/lib/libglib-2.0.so.0(g_spawn_sync+0x14b)[0xb782cecb]
/usr/lib/libglib-2.0.so.0(g_spawn_command_line_sync+0x9c)[0xb782d38c]
pidgin(pidgin_setup_imhtml+0x174)[0x80f6984]
pidgin(pidgin_create_imhtml+0x1a6)[0x80f6b86]
pidgin[0x80ec3b9]
/usr/lib/libgobject-2.0.so.0(g_type_create_instance+0x445)[0xb789def5]
/usr/lib/libgobject-2.0.so.0[0xb78823f5]
/usr/lib/libgobject-2.0.so.0(g_object_newv+0x376)[0xb7882c26]
/usr/lib/libgobject-2.0.so.0(g_object_new_valist+0x2e2)[0xb7883812]
/usr/lib/libgobject-2.0.so.0(g_object_new+0x6e)[0xb788395e]
pidgin(pidgin_status_box_new+0x3b)[0x80ea9cb]
pidgin[0x808696e]
/usr/lib/libpurple.so.0(purple_blist_show+0x2d)[0xb770befd]
pidgin(main+0x7cc)[0x80c311c]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5)[0xb7576775]pidgin[0x806db61]
======= Memory map: ========
08048000-0810e000 r-xp 00000000 08:01 9569946    /usr/bin/pidgin
0810e000-0810f000 r--p 000c5000 08:01 9569946    /usr/bin/pidgin
0810f000-08112000 rw-p 000c6000 08:01 9569946    /usr/bin/pidgin
08ebd000-0933f000 rw-p 08ebd000 00:00 0          [heap]
b5900000-b5921000 rw-p b5900000 00:00 0 
b5921000-b5a00000 ---p b5921000 00:00 0 
b5aaa000-b5ab7000 r-xp 00000000 08:01 21856321   /lib/libgcc_s.so.1
b5ab7000-b5ab8000 r--p 0000c000 08:01 21856321   /lib/libgcc_s.so.1
b5ab8000-b5ab9000 rw-p 0000d000 08:01 21856321   /lib/libgcc_s.so.1
b5ab9000-b5ad1000 r--s 00000000 08:01 9666951    /usr/share/mime/mime.cache
b5ad1000-b5aeb000 r-xp 00000000 08:01 9594069    /usr/lib/gio/modules/libgvfsdbu
s.so
b5aeb000-b5aec000 r--p 00019000 08:01 9594069    /usr/lib/gio/modules/libgvfsdbu
s.so
b5aec000-b5aed000 rw-p 0001a000 08:01 9594069    /usr/lib/gio/modules/libgvfsdbu
s.so
b5aed000-b5aff000 r-xp 00000000 08:01 9571440    /usr/lib/libgvfscommon.so.0.0.0
b5aff000-b5b00000 r--p 00012000 08:01 9571440    /usr/lib/libgvfscommon.so.0.0.0
b5b00000-b5b01000 rw-p 00013000 08:01 9571440    /usr/lib/libgvfscommon.so.0.0.0
b5b13000-b5b22000 r-xp 00000000 08:01 9594068    /usr/lib/gio/modules/libgioremo
te-volume-monitor.so
b5b22000-b5b23000 r--p 0000e000 08:01 9594068    /usr/lib/gio/modules/libgioremo
te-volume-monitor.so
b5b23000-b5b24000 rw-p 0000f000 08:01 9594068    /usr/lib/gio/modules/libgioremo
te-volume-monitor.so
b5aed000-b5aff000 r-xp 00000000 08:01 9571440    /usr/lib/libgvfscommon.so.0.0.0
b5aff000-b5b00000 r--p 00012000 08:01 9571440    /usr/lib/libgvfscommon.so.0.0.0
b5b00000-b5b01000 rw-p 00013000 08:01 9571440    /usr/lib/libgvfscommon.so.0.0.0
b5b13000-b5b22000 r-xp 00000000 08:01 9594068    /usr/lib/gio/modules/libgioremo
te-volume-monitor.so
b5b22000-b5b23000 r--p 0000e000 08:01 9594068    /usr/lib/gio/modules/libgioremo
te-volume-monitor.so
b5b23000-b5b24000 rw-p 0000f000 08:01 9594068    /usr/lib/gio/modules/libgioremo
te-volume-monitor.so
b5b24000-b5b6a000 r-xp 00000000 08:01 25190403   /usr/lib/nss/libnssckbi.so
b5b6a000-b5b72000 r--p 00045000 08:01 25190403   /usr/lib/nss/libnssckbi.so
b5b72000-b5b76000 rw-p 0004d000 08:01 25190403   /usr/lib/nss/libnssckbi.so
b5b76000-b5bba000 r-xp 00000000 08:01 25190402   /usr/lib/nss/libfreebl3.so
b5bba000-b5bbb000 r--p 00043000 08:01 25190402   /usr/lib/nss/libfreebl3.so
b5bbb000-b5bbc000 rw-p 00044000 08:01 25190402   /usr/lib/nss/libfreebl3.so
b5bbc000-b5bf0000 r-xp 00000000 08:01 25190406   /usr/lib/nss/libsoftokn3.so
b5bf0000-b5bf1000 r--p 00034000 08:01 25190406   /usr/lib/nss/libsoftokn3.so
b5bf1000-b5bf2000 rw-p 00035000 08:01 25190406   /usr/lib/nss/libsoftokn3.so
b5bf2000-b5c04000 r-xp 00000000 08:01 25362442   /usr/lib/purple-2/libirc.so
b5c04000-b5c05000 r--*** glibc detected *** pidgin: free(): invalid pointer: 0x0
8f024a0 ***
^C
ben@xxx:~$

comment:6 Changed 10 years ago by bewest

I don't know if this is related, but the following also appears in my ~/.xsession-errors:

Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x400002c (Buddy List)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

comment:7 Changed 10 years ago by bewest

$valgrind -v --log-file="valgrind-pidgin`date +%F`-%p.log" --trace-children=yes --leak-check=full --track-origins=yes  pidgin -n 
Produced:
$ls -lh valgrind-pidgin2009-05-14-8*
-rw------- 1 ben uucp 255K 2009-05-14 18:07 valgrind-pidgin2009-05-14-8185.log
-rw------- 1 ben uucp  25K 2009-05-14 18:01 valgrind-pidgin2009-05-14-8192.log
-rw------- 1 ben uucp  25K 2009-05-14 18:04 valgrind-pidgin2009-05-14-8198.log
-rw------- 1 ben uucp  25K 2009-05-14 18:04 valgrind-pidgin2009-05-14-8202.log
-rw------- 1 ben uucp  25K 2009-05-14 18:06 valgrind-pidgin2009-05-14-8222.log
-rw------- 1 ben uucp  25K 2009-05-14 18:07 valgrind-pidgin2009-05-14-8226.log
$

Changed 10 years ago by bewest

1 of 6

Changed 10 years ago by bewest

2 of 6

Changed 10 years ago by bewest

3 of 6

Changed 10 years ago by bewest

4 of 6

Changed 10 years ago by bewest

6 of 6

Changed 10 years ago by bewest

5 of 6

comment:8 Changed 10 years ago by bewest

When run under valgrind, the glibc complaint does not appear, and although valgrind warns of problems, pidgin is able to log into my account without hanging. Same for the Help->About dialog.

comment:9 Changed 10 years ago by deryni

What happens if you run:

gconftool-2 -g /desktop/gnome/interface/document_font_name

as your normal user and root? Does it work for one and not the other?

What happens if you run pidgin as:

GNOME_DESKTOP_SESSION_ID= pidgin

as your normal user? Does pidgin still crash?

Are you indicating that if you run pidgin in gdb when it hangs and you hit ctrl-c to get dropped to the gdb prompt running 'bt' produces no results?

comment:10 Changed 10 years ago by bewest

$gconftool-2 -g /desktop/gnome/interface/document_font_name 
Sans 10
$sudo gconftool-2 -g /desktop/gnome/interface/document_font_name 
[sudo] password for ben: 
Sans 10
$GNOME_DESKTOP_SESSION_ID= pidgin 
*** glibc detected *** pidgin: free(): invalid pointer: 0x0988c4a0 ***
*** glibc detected *** pidgin: free(): invalid pointer: 0x0988c4a0 ***

With GNOME_DESKTOP_SESSION_ID unset, signing on still produces an error regarding free(), but the GUI remains responsive. I was able to access Help->About without any errors this time.

This is what is printed on the console:

$GNOME_DESKTOP_SESSION_ID= pidgin 
*** glibc detected *** pidgin: free(): invalid pointer: 0x0988c4a0 ***
*** glibc detected *** pidgin: free(): invalid pointer: 0x0988c4a0 ***

This involved signing on/off twice, and accessing Help->About several times.

The signing on process did not succeed; just a blank buddy list.

I just tried it again and got a backtrace. Let me try again with GNOME_DESKTOP_SESSION_ID unset. Both backtraces coming.

Changed 10 years ago by bewest

ctr-c produced a backtrace for me.

comment:11 Changed 10 years ago by deryni

That backtrace, like the earlier one, appears to be crashing when spawning gconftool-2 to lookup that font setting. I cannot see why that would be happening. What version of GTK+ are you using?

comment:12 Changed 10 years ago by bewest

libgtk2.0-0 provided by a fresh install of ubuntu

2.16.1-0ubuntu2

I actually think it has something to do with dns/setting up the connection, but I'm not sure why it wouldn't matter when run as root.

Changed 10 years ago by bewest

looks like something related to requesting dns?

comment:13 Changed 10 years ago by bewest

I now believe this is caused by a plugin. Using ubuntu's package manager to uninstall ALL plugins seems to relieve any issue.

I thought having all plugins unchecked would be sufficient. After re-installing just the OTR ( off the record ) plugin, the symptoms reappeared: Help->About and attempting to sign on to any service causes glibc to complain of free( )ing an invalid pointer.

Where is the right place to send this information?

comment:14 Changed 10 years ago by deryni

The OTR plugin authors have a website at http://www.cypherpunks.ca/otr/ but you may want to start by filing a bug with Ubuntu instead.

Changed 10 years ago by nralu

The backtrace for my problem, i guess it has something to do with jabber

comment:15 Changed 10 years ago by nralu

  • Status changed from pending to new

Attachment (bt-_17.05.2009.txt) added by ticket reporter.

comment:17 Changed 10 years ago by deryni

  • Status changed from new to pending

nralu: Your problem is #8830.

I'm marking this pending since whatever issues bewest is still tracking down are unrelated to this issue and should get a new ticket if they need more work.

comment:18 Changed 10 years ago by QuLogic

  • Owner changed from lschiere to rekkanoryo

comment:19 Changed 10 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!