Opened 10 years ago

Closed 10 years ago

Last modified 3 years ago

#9192 closed enhancement (out of date)

No Autodetect Proxy

Reported by: Trhenning Owned by: sulabh.dev
Milestone: Component: Yahoo!/Yahoo! JAPAN
Version: 2.6.1 Keywords:
Cc:

Description (last modified by rekkanoryo)

Hi all.

After network firewall upgrades, Pidgin seems to have lost the ability to properly connect to Yahoo and AOL messaging. The AOL and Yahoo clients themselves have no problem connection, however, pidgin seems to have a problem completing the handshake.

Here is the debug window:

(09:47:05) account: Connecting to account trhenning05
(09:47:05) connection: Connecting. gc = 026489B0
(09:47:05) proxy: No Windows proxy set.
(09:47:05) dnsquery: Performing DNS lookup for scs.msg.yahoo.com
(09:47:05) dnsquery: IP resolved for scs.msg.yahoo.com
(09:47:05) proxy: Attempting connection to 66.163.181.183
(09:47:05) proxy: Connecting to scs.msg.yahoo.com:5050 with no proxy
(09:47:05) proxy: Connection in progress
(09:47:06) proxy: Connecting to scs.msg.yahoo.com:5050.
(09:47:06) proxy: Error connecting to scs.msg.yahoo.com:5050 (Connection refused.).
(09:47:06) proxy: Connection attempt failed: Connection refused.
(09:47:06) account: Disconnecting account 00C9EFF0
(09:47:06) connection: Disconnecting connection 026489B0
(09:47:06) connection: Destroying connection 026489B0
(09:47:06) util: Writing file prefs.xml to directory C:\Documents and Settings\Timothy-Henning\Application Data\.purple
(09:47:06) util: Writing file C:\Documents and Settings\Timothy-Henning\Application Data\.purple\prefs.xml
(09:47:10) util: Writing file accounts.xml to directory C:\Documents and Settings\Timothy-Henning\Application Data\.purple
(09:47:10) util: Writing file C:\Documents and Settings\Timothy-Henning\Application Data\.purple\accounts.xml

with Yahoo, the newest version, I have to select the "Connect via a proxy server", and the type of "HTTP" However, Ymsgr takes care of the rest. AIM is very similar. Is there any way to add this functionality to Pidgin?

Best,

Tim

Change History (5)

comment:1 Changed 10 years ago by rekkanoryo

  • Description modified (diff)
  • Milestone set to Patches welcome
  • Type changed from patch to enhancement

This ticket does not contain a patch.

comment:2 Changed 10 years ago by StTwister

Maybe port 5050 is blocked by your firewall. The official client might fallback to port 80. Try changing the port from 5050 to 80 in the account settings. I know for sure that Yahoo! also allows connection on port 80 on scs.msg.yahoo.com

comment:3 Changed 10 years ago by rekkanoryo

  • Owner changed from marv to sulabh.dev
  • Version changed from 2.5.5 to 2.6.1

Updating ticket to reflect the new primary maintainer of our Yahoo! code.

comment:4 Changed 10 years ago by sulabh.dev

  • Resolution set to out of date
  • Status changed from new to closed

It appears from the debug log that this issue was with the older versions of Pidgin (before v 2.5.7). Pidgin now uses a different mechanism to log into Yahoo account. Also using the same proxy as set in the gnome environment and setting separate proxy per account is supported.

Pidgin 2.6.2 shouldn't cause the problem reported in this bug. File a new ticket if you see a similar problem.

comment:5 Changed 3 years ago by Robby

  • Milestone Patches welcome deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!