Opened 10 years ago

Closed 8 years ago

#9244 closed defect

Odd encoding break massively

Reported by: Plantain Owned by:
Milestone: Component: libpurple
Version: 2.5.6 Keywords: utf8 encoding broken
Cc:

Description

A friend has her name set as "-+†• کђяﺙввεя★™ •†+-", which renders combined with her message as

"ввεя★™ •†+-: haha(22:09:26) -+†• کђяﺙ"

I can provide screenshots if necessary, but it's not hard to reproduce...

Change History (6)

comment:1 Changed 10 years ago by deryni

  • Status changed from new to pending

Is this Windows?

comment:2 Changed 10 years ago by deryni

Is #9261 what you are seeing?

comment:3 Changed 10 years ago by Plantain

  • Status changed from pending to new

This is Gentoo Linux.

It's similar to whats in that picture (it breaks the same way), but this breakage is caused by the nickname of the person, not the message. I can send it in a message without breaking.

comment:4 Changed 8 years ago by chemistrydioxide

That nickname seems to consist of a mixture of left-to-right and right-to-left characters, and rendering such text is not trivial. I'm not sure whether this bug tracker and/or some browser has a similar problem, so it would be useful if you could provide a screenshot of both the correct nickname and how it appears to you.

comment:5 Changed 8 years ago by deryni

  • Status changed from new to pending

Given that this ticket is from the same period of time as #9264 I'm going to guess that this is likely the same problem and was fixed by the same fix. Marking this pending unless someone reports that it is still happening.

comment:6 Changed 8 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!