Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#9290 closed enhancement (wontfix)

irc: automatic alternative nick should be generated by adding an underscore

Reported by: mhaecker Owned by: elb
Milestone: Component: IRC
Version: 2.5.6 Keywords:
Cc: Nescafe

Description

Well, this is not what I prefer most, but what the bootload of other clients do by default - and therefore lots of applications expect (e.g. freenode tells the user in the documentation for nickserv to do it this way: http://freenode.net/faq.shtml#nicksetup

Therefore libpurple should follow these defaults and should make any deviation from this rule as a configurable option.

It just cost me (a somewhat advanced user) about 20 minutes to figure this out after being bugged by it for about two weeks - so I think this is probably as much a usability bug.

Change History (6)

comment:1 Changed 10 years ago by mhaecker

That option would enable clients like pidgin to remain backwards compatible, while other clients (like Adium) that would like to change can get the more standard behaviour.

Best Regards, Martin

comment:2 Changed 10 years ago by deryni

  • Status changed from new to pending

The freenode documentation uses foo_ as an example of what many clients do, there is *no* expectation that all clients will do it, and if your client doesn't do that (as pidgin does not) you can use those same directions with the pidgin alternate nicknames and they will work perfectly well.

I see no reason to change what pidgin already does, any application that assumes a certain style is broken, and using a single underscore prevents multiple attempts from succeeding (without using multiple underscores which looks decidedly less friendly at higher counts than does an increasing integer).

There is no "backwards compatability" issue here as this is not a feature anything can or should be counting on.

comment:3 follow-up: Changed 10 years ago by mhaecker

  • Status changed from pending to new

Well if there is no standard with something it is always the best to do what most other people do - as uniformity is easier to explain in almost all circumstances and therefore makes life much easier for users.

If you feel that as a power user this policy does not fit you i can relate to that. But then again, perhaps many clients that are based on libpurple would like it to behave this way to ease their users life.

Therefore I ask for this (on behalf of the Adium team)

Regards, Martin

comment:4 in reply to: ↑ 3 Changed 10 years ago by elb

Replying to mhaecker:

Well if there is no standard with something it is always the best to do what most other people do - as uniformity is easier to explain in almost all circumstances and therefore makes life much easier for users.

The problem is that "most" doesn't apply here. The behavior we have now is very similar to the behavior of irssi, which is a very popular client.

There is no uniformity in this behavior, this argument is specious.

If you feel that as a power user this policy does not fit you i can relate to that. But then again, perhaps many clients that are based on libpurple would like it to behave this way to ease their users life.

Our behavior has one major advantage over appending _s, which is not obvious to many because several popular IRC networks now have very long nick limits -- we have 9 alternate nicks in the space of one character. Note that freenode, your reference for a server recommending appending underscores, is a network which allows very long nicks.

I truly feel that the current behavior is a technically superior solution, and I would have to hear some strong arguments for changing it, which I have not so far. For review, the current behavior is as follows:

  1. Upon setting a nick, look to see what comes back in the nick used numeric; if the string coming back is shorter than the nick we chose, shorten our nick to the length of the returned nick - 1 char.
  2. If the last digit of the nick is a digit, increment it; if not, append a 1 to the nick. Try again.
  3. If a subsequent nick used message comes back, increment the digit. Wrap '9' to '1' if necessary.

This is certainly both more flexible and more aesthetically pleasing (the latter being subjective, I realize) than an ever-increasing tail of underscores.

Ethan

comment:5 Changed 10 years ago by mhaecker

  • Resolution set to wontfix
  • Status changed from new to closed

Well, I don't think I can make you change your mind - also your reasons are pretty sound.

And having even more options doesn't sound right to me either, so I'll stand down.

Best Regards, Martin

comment:6 Changed 9 years ago by Nescafe

Couldn't there be an alternative nick list so that we can explicitly configure how we want Pidgin to handle collisions, falling back to the current generation once exhausted ?

I'd like Pidgin to try Nescafe, Nescafe|Pidgin, Nes and only then the Nescafe1, Nescafe2 family. Other users could fill the list with Nick, Nick_, Nick, Nick_ if they like it that way.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!