Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9312 closed defect (duplicate)

file transfer crash

Reported by: mikaelz Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.5.6 Keywords: crash, file transfer
Cc:

Description

someone sent me a file transfer request through the MSN protocol. I accepted; instead of beginning the transfer, Pidgin crashed. I repeated this 3 times and it keeps happening. running 2.5.6 on XP SP2

the error that pops up says:

Assertion failed!

Program: C:\Program Files\Pidgin\pidgin.exe File: cairo.c Line: 87

Expression: _cario_status_is_error (status)

Change History (7)

comment:1 Changed 10 years ago by khc

  • Component changed from MSN to winpidgin (gtk)
  • Owner changed from khc to datallah

comment:2 Changed 10 years ago by khc

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #8129.

comment:3 Changed 10 years ago by mikaelz

this is not a duplicate of #8129 since Pidgin did not crash on startup but rather when a file transfer was initiated.

comment:4 Changed 10 years ago by khc

it's crashing in the same library, can you try the workaround in http://developer.pidgin.im/ticket/8129#comment:38

comment:5 Changed 10 years ago by datallah

I think this is actually a duplicate of #8565 (it is caused by the clearlooks theme).

comment:6 Changed 10 years ago by mikaelz

khc, I reinstalled GTK and replaced the files as requested, no dice

datallah, you are right. changing the theme from Clearlooks to MS-Windows fixed the issue.

comment:7 Changed 10 years ago by mikaelz

thank you.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!