Opened 12 years ago

Last modified 8 years ago

#938 new defect

Sent message not shown sometimes (when animated smileys used)

Reported by: rpolach Owned by: seanegan
Milestone: Component: pidgin (gtk)
Version: 2.0 Keywords:
Cc: cringer0, yelo3, xerces8

Description

I have installed QIP-like smiley theme (in ~/.purple/smileys/qip/) and switched to it. Very often when I send a message, the message does not appear in conversation window immediately... it appears only if when I receive the next message.. or when I resize the conversation dialog a little bit.. or I clicked or dragged the empty place where the text is expected.. I see this behavior only when I am switched to this QIP smiley theme...

Affected versions:

  • pidgin 2.0.0 in Ubuntu Linux (from getdeb.net)
  • pidgin 2.0.0 in Windows
  • gaim 2.0.0.beta6 in Ubuntu Linux (Feisty)
  • gaim 2.0.0.beta6 in Windows

Note: for 2.0.0 betas I was used ~/.gaim/smileys/qip/ of course

Attachments (1)

gaim-QIPsmileys.tar.gz (149.0 KB) - added by rpolach 12 years ago.
QIP-like theme (with animated GIFs) for Pidgin

Download all attachments as: .zip

Change History (43)

Changed 12 years ago by rpolach

QIP-like theme (with animated GIFs) for Pidgin

comment:1 Changed 12 years ago by lschiere

  • Milestone set to 2.0.1
  • Owner set to seanegan

comment:2 Changed 12 years ago by seanegan

  • Milestone changed from 2.0.1 to 2.0.2
  • pending changed from 0 to 1

I cannot reproduce this.

What version GTK+ are you using? For Windows, you can tell this in Help > About.

What is the "Use Smooth Scrolling" option set to?

How many smileys must a message have to cause this to happen? Can it happen with only one or does it have to, say, over 20?

Is it a combination of text and smileys that does the trick, or can it happen if there's only a single smiley in the message? Are certain of those smileys more likely than others to cause it?

Is there one particular message that might perhaps reproduce this problem consistantly?

comment:3 Changed 12 years ago by rpolach

  • pending changed from 1 to 0

Windows GTK+ version: 2.10.11.

Ubuntu GTK+ version: the same (actual version in Feisty repo)

Use smooth scrolling = yes.

There is no particular number of images to reproducible behavior. I do not understand why sometimes this problem is seen and sometimes not, I simply see it sometimes but not always. A one smiley next to one short word would be sufficient, but it is dependent on previous conversation content (last line width and height?) and window size probably.

comment:4 Changed 12 years ago by rpolach

I can see the problem e.g. in this situation:

  • Conversation window shows only few messages now, so there is a lot of vertical space to show about 5 future message lines (without scrolling!)
  • The Window is large also horizontally, so approximately 40 single smileys fits into one line

In this situation someone sends this message to me (3 characters - without newlines):

:-\

Then I send this message (without newlines):

*IN_LOVEKISSINGIN_LOVEKISSINGIN_LOVEKISSINGIN_LOVEKISSING*

(it takes less than a half of window width) This message won't appear unless I resize window (or do another action described in this bug description)

comment:5 Changed 12 years ago by rpolach

I see the problem also with this: There is large conversation window and only few messages displayed - like in previous comment...

I send two messages:

The first one is only one word and one smiley - :-) or ;-) one...

The second message has no smileys at all but its length is significantly larger than of previous one (but not as large as it fits window width)

comment:6 Changed 12 years ago by seanegan

  • Status changed from new to assigned

I still cannot reproduce with the steps you provide. What GTK+ theme are you using?

comment:7 Changed 12 years ago by rpolach

On Linux: Ubuntu's default "Human" theme,

on Windows: some default theme comes with bundled GTK+ 2.10.11 b.

comment:8 Changed 12 years ago by rpolach

I don't know if the behavior could be dependent on active plugins, but for sure... I use these plugins in Pidgin 2.0.1 / Ubuntu:

  • Buddy State Notification
  • History
  • Libnotify popups
  • Message Notification
  • Message Timestamp formats.

I also see very often the problem, when sending a first message of conversation even if it does not contain any smileys (so there is only history (containing some smileys) + horizontal line displayed in conversation area before..)

comment:9 Changed 12 years ago by rpolach

I should note that I see this problem with ICQ protocol (I did not try other)

comment:10 Changed 12 years ago by Pay

I have exactly the same problem! I am using a animated ICQ6 Smiley package. I also use Pidgin just for ICQ. Running with Ubuntu 7.04 Feisty Kernel 2.6.20-16-generic, GTK 1.2.10-18 and following Plugins:

-Libnotify popups

-Message Timestamp formats.

-History

-New line

comment:11 Changed 12 years ago by seanegan

  • Milestone changed from 2.0.2 to 2.1.0

I still am unable to reproduce it. I'll try again for next release. can any other developer repro this?

comment:12 Changed 12 years ago by datallah

I can reproduce this with the attached smiley theme by sending the following a couple times:

O:-):-):-(;-):-P8-):-D*TIRED*:-[=-O:-*:'(:-X>:o:-|:-\*JOKINGLY*]:->[:-}*KISSED*:-!*TIRED**STOP**KISSING*@}->--*THUMBS UP**DRINK**IN LOVE*@=*HELP*\m/%)*OK**WASSUP**SORRY**BRAVO**ROFL**PARDON**NO**PARDON**CRAZY**DONT_KNOW**DANCE**YAHOO*

There are a bunch of asserts displayed.

I think this is related to the crash in Windows reported in #1594.

comment:13 Changed 12 years ago by kobedf

I will attach here 2 small conversations that have showed this bug.
I would like to mention that it happens a lot and it is annoying.
I am using Pidgin 2.0.2 on windows.
Texts are in Romanian but i doubt that this matters.
Bold lines did not appear .Only after sending another mess or minimizing.

(21:46:56) xxx: :d
(21:47:00) yyy: ca nu se poate sa sufar in halul asta
(21:47:12) xxx: ce fain...tot dupa racoare te muti...desi si acolo e cald:))
(21:47:27) yyy: pai o fi.....dar astra e....
(21:47:39) yyy: :p
(21:47:58) xxx: aha...deci ai tem de vizitat europa si acum incepi cu rom cat mai ai timp?:))
(21:48:17) yyy: pai daca trebuie ...trebuie :d
(21:48:44) xxx: pai d c trebuie?
(21:49:31) yyy: pai ca vreau :D
(21:49:43) yyy: imi place

second:

aaa: dap

(21:45:43) bbb: pai fa ceva cu el :d
(21:46:03) bbb: poate scrie pe acolo
(21:46:34) bbb: si apoi cand cere informatiile alea pune numa liniute

comment:14 Changed 12 years ago by kobedf

something else...as a smiley theme i am using i have no idea what but it says Original - M@her in the description I use pidgin with the yahoo protocol

comment:15 Changed 12 years ago by seanegan

  • pending changed from 0 to 1

Is there a chance that the auto-resizing of the input box when composing a sent message is causing the top box to scroll up a bit. Then, when the message is sent, the top box doesn't scroll down because it's not already at the bottom?

That's the only thing I can think that would cause this right now, and I want to try to fix it.

comment:16 Changed 12 years ago by N00byStance

I have the same problem, and I think this is network-independent. I am using Gadu-Gadu animated smiley set.

When I enter a message with an animated smiley, it sometimes appears, and sometimes not. What I do is usually select the text, or do something text-related, and it appears.

comment:17 Changed 12 years ago by seanegan

  • Resolution set to worksforme
  • Status changed from assigned to closed

I don't know why it wasn't closed automatically, but it's been pending for a while.

comment:18 Changed 12 years ago by rpolach

  • pending changed from 1 to 0

this problem seems to be reproduced undeterministicly; but is it the reason to do not solve it at all? I see this problem regularly several times a day, it is real.

comment:19 Changed 12 years ago by kobedf

What i cannot understand is why this defect is categorized as minor. It is extremely annoying. I stopped using Pidgin and went back to the resource hog Yahoo Messenger that at least works reliably every time and never crashes.

comment:20 Changed 12 years ago by datallah@…

  • Milestone changed from 2.1.1 to 2.2.1
  • Resolution changed from worksforme to fixed

(In 23f10058988472a234b0d4870c83d0f6136da47d) Fix some crashes with animated smileys. Fixes #3179, #938, #3134, #2872, #1594

comment:21 Changed 11 years ago by rpolach

this problem is back for me - in Pidgin 2.2.2 for Windows, should be this reopened or should I fill new ticket?

comment:22 Changed 11 years ago by kobedf

It never went away for me. And it's happening at an annoying rate. I do not understand why it was changed to fixed. But you do get used to it after some time.....nothing is perfect.

comment:23 Changed 11 years ago by rpolach

could this bug be reopened please?

comment:24 Changed 11 years ago by rpolach

also another user confirms that the probles still exists in 2.3.0 https://bugs.launchpad.net/ubuntu/+source/gaim/+bug/67224 - see https://bugs.launchpad.net/ubuntu/+source/gaim/+bug/67224/comments/15

Should another ticket be open for this problem on 2.3.0?

comment:25 Changed 11 years ago by oxmosys

I would say : yes.. You can also speak to pidgin developers on #pidgin channel in freenode.

comment:26 Changed 11 years ago by seanegan

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:27 Changed 11 years ago by rpolach

The problem appears for me (in 2.3.1/windows and 2.3.0/linux) when:

1) an animated smiley used

2) the chat window is first filled by messages so vertical scrollbar starts scrolling down..

3) the window is resized, so scrolling is not needed anymore and there is a free space in chat window at least for one more message to appear without need of scrollbar activated again...

4) some animated smiley is already displayed in chat window..

5) user sends a message then ...

Note 1: I didn't see the problem, if other smiley theme (or no theme at all) is used.

Note 2: The problem is also seen sometimes when message is received.

comment:28 Changed 11 years ago by oxmosys

I confirm this bevahior with Pidgin 2.2.1 in Linux Ubuntu.

comment:29 Changed 11 years ago by kobedf

Guys..... you have to do something about this. Maybe all the guys that are complaining did not say this the right way IT IS VEEEERYYY!!! annoying Why did you put this thread on close or fixed two times???? Get the basic stuff working guys before you try advanced features. let me repeat myself. It is VERY VERY annoying.

Thank you

comment:30 Changed 11 years ago by trisweb

Confirm this behavior in Pidgin 2.3.1 and 2.4 in Windows XP.

Using an animated smiley theme ported from Skype.

Even if a single smiley is in the chat window, indeterminately, lines will not appear, either ones I have sent or sometimes (but less often) received while the window is focused.

I can confirm it still happens when rpolach's steps above are followed, but I can also say for sure it happens for new conversations where scrollbars are not yet needed and there is space to fill in the window.

Once scrolling starts this seems not to happen anymore (I'm guessing as it's re-rendered with each message due to the scroll).

Disabling animated smilies (using another theme) is an acceptable workaround for now, but this should still be fixed. Thanks :)

comment:31 Changed 11 years ago by kobedf

I confirm it too for 2.3.1 and 2.4 on Linux Red Hat Enterprise Linux 5, Kernel 2.6

comment:32 Changed 11 years ago by kobedf

Still there in 2.4.1. Still annoying

comment:33 in reply to: ↑ description Changed 11 years ago by occasus

Confirmed in Pidgin 2.4.1 under Ubuntu 8.04. It happens for Yahoo! Smiley theme created by Andrei Neculau: http://andreineculau.com/blog/2008/04/original-smileys/#comment-405

comment:34 Changed 10 years ago by datallah

Ticket #8398 has been marked as a duplicate of this ticket.

comment:35 Changed 10 years ago by kobedf

Still there in 2.5.4 Are you guys ever going to solve this (really annoying) problem?

comment:36 Changed 10 years ago by deryni

Can someone who is still experiencing this issue post explicit step-by-step directions for how to recreate this issue? Including what GTK+ version is being used and what smiley theme is in use? Indicating that the steps posted above work is fine. Ideally the steps would cause the issue to occur every time and not just sometimes. Additionally, can someone confirm that they see this when the window still has room to display new lines and therefore that this doesn't have to do with scrolling of the history area?

comment:37 Changed 10 years ago by kobedf

I will try to come up with a scenario that can be recreated. However , I am not sure this is even possible. Anyway....I wanted to re-explain a few things

  1. It happens very often. If I have a conversation that last for 1 hour this will probably happens more than 20-30 times.
  2. Minimizing the chat window makes the hidden lines appear
  3. Any text sent by the person that I am speaking to makes the hidden lines appear
  4. Any text I write makes the hidden lines appear but at the same time those new lines

are not shown.

comment:38 Changed 10 years ago by rekkanoryo

  • Milestone 2.2.1 deleted

comment:39 Changed 10 years ago by cringer0

The same thing is occurring with the newest version. My smileys are also animated.

Windows XP Professional SP2 -- Pidgin v2.5.5 -- GTK v2.14.7 Rev a -- GTK Theme Used is ThinIce?.

comment:40 Changed 9 years ago by xerces8

Also see mail list thread: http://pidgin.im/pipermail/support/2008-March/000997.html

Happens all the time, since ages. Now I am using 2.6.3 (on windows XP).

I have smooth scroll OFF. No custom themes or plugins.

What happens is like this:

  • I'm in a MSN chat
  • the peer "writes" an animated smiley
  • I type some regular text

Result: my text does not appear in the chat

If I refresh the window (for example by covering and uncovering it), my text appears.

Happens often and is annoying. Very.

comment:41 Changed 9 years ago by a2mics

Just experienced this issue with Pidgin 2.6.6 on Windows XP SP3 (Feb 2010)! I have installed the custom smileys theme from here: http://www.gnome-look.org/CONTENT/content-files/59794-Original.tar.gz. This issue seem to appear and dissapear from one version to another, does any developer actively looking into it?

comment:42 Changed 9 years ago by rpolach

For me, problem is seen in every pidgin version, and almost in every message (when history plug-in is enabled and animated smileys used).

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!