Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9414 closed defect (fixed)

Yahoo! fails to connect, connecting forever

Reported by: gagern Owned by: marv
Milestone: 2.5.7 Component: Yahoo!/Yahoo! JAPAN
Version: 2.5.6 Keywords:
Cc: mjollnir76, gjmsreddy, pozunmv, dlevine278

Description (last modified by gagern)

Had my Yahoo account working in the past, but it fails to connect now. Instead Pidgin remains "Connecting" seemingly forever. Maybe they changed something for the Yahoo server(s)?

Running "pidgin -d" on the command line gives me these lines when I enable Yahoo:

proxy: Attempting connection to 68.180.217.12
proxy: Connecting to scs.msg.yahoo.com:5050 with no proxy
proxy: Connection in progress
proxy: Connecting to scs.msg.yahoo.com:5050.
yahoo: 93 bytes to read, rxlen is 113
yahoo: Yahoo Service: 0x57 Status: 1
yahoo: yahoo status: 0

I also have used wireshark to look at the packets transmitted, in case they are of any use to you:

  • sent service=0x57 status=0 key=1
  • reveived service=0x57 status=1 keys=1,13,94
  • sent service=0x54 status=0 keys=0,6,96,1,244,135

I encountered and investigated the issue on Linux, but I got a report from a Windows user deswcribing the same connection problem.

Maybe ticket #9411 has the same cause as well, I don't know.

Attachments (1)

AccountInfo.xml_bak (8.3 KB) - added by avatar666 10 years ago.
http://www.yahoo mail.it

Download all attachments as: .zip

Change History (38)

comment:1 Changed 10 years ago by robholmes

I am experiencing exactly the same issue using v2.5.6 on Ubuntu 9.04, in fact the issue was also present for me in v2.5.5, which led me to upgrade to v2.5.6.

Hope we can get this resolved asap.

If any extra debug info is required don't hesitate to ask.

Thanks, Rob

comment:2 Changed 10 years ago by mjollnir76

I am experiencing the same issue: Ubuntu 9.04 and v2.5.5 was not connecting to Yahoo (the status bar just sits on "Available - waiting to connect") so I upgraded to v2.5.6 and I still have the same problem.

Oddly enough, yesterday one of my Yahoo accounts worked, the other two Yahoos did not, and my Hotmail did. Today, none of the Yahoo's will work, but the Hotmail still does.

Thanks for any help people can give. I would post the debug info, but I'm not sure how much is needed.

Thanks again! Matthew

comment:3 follow-up: Changed 10 years ago by SlumberJack

This appears to be a DNS/IP address issue with the yahoo servers. Changing the Page Server from scs.msg.yahoo.com to 66.163.181.167 has resolved the issue for me. The hostname was resolving to 76.13.15.36 which may be dead/faulty.

Cheers

Richard

comment:4 Changed 10 years ago by gjmsreddy

Thanks Richard. Changing IPAddress resolves the issue for me.

Jagan.

comment:5 in reply to: ↑ description Changed 10 years ago by Ceed19

I am using Pidgin Portable 2.5.6 and I too am having this same problem. Infinitely connecting to yahoo accounts.

comment:6 Changed 10 years ago by pozunmv

Having the same issues with yahoo accounts as well. Ive seen the issue on 5 different machines, running 2.5.6 and 2.5.5 (I believe but it may be an older version as well) 2.5.6 on 2 windows XP professional machines 2.5.5? on Suse 10.3 2.5.6 on Suse 11.1 2.5.6 on Ubuntu 9.04

Attached is the debug from a windows xp instance, the log contains to connection attempts

(08:07:17) account: Connecting to account *******
(08:07:17) connection: Connecting. gc = 021BE5D8
(08:07:17) dnsquery: Performing DNS lookup for scs.msg.yahoo.com
(08:07:17) dnsquery: IP resolved for scs.msg.yahoo.com
(08:07:17) proxy: Attempting connection to 68.180.217.7
(08:07:17) proxy: Connecting to scs.msg.yahoo.com:5050 with no proxy
(08:07:17) proxy: Connection in progress
(08:07:18) proxy: Connecting to scs.msg.yahoo.com:5050.
(08:07:18) yahoo: 96 bytes to read, rxlen is 116
(08:07:18) yahoo: Yahoo Service: 0x57 Status: 1
(08:07:18) yahoo: yahoo status: 0
(08:22:02) account: Connecting to account *******
(08:22:02) connection: Connecting. gc = 03A1AA48
(08:22:02) dnsquery: Performing DNS lookup for scs.msg.yahoo.com
(08:22:02) dnsquery: IP resolved for scs.msg.yahoo.com
(08:22:02) proxy: Attempting connection to 76.13.15.34
(08:22:02) proxy: Connecting to scs.msg.yahoo.com:5050 with no proxy
(08:22:02) proxy: Connection in progress
(08:22:02) proxy: Connecting to scs.msg.yahoo.com:5050.
(08:22:02) yahoo: 94 bytes to read, rxlen is 114
(08:22:02) yahoo: Yahoo Service: 0x57 Status: 1
(08:22:02) yahoo: yahoo status: 0

Connections from this machine work with another client when connecting to yahoo with the same server defined. Verified with wireshark the other client is resolving the ip to the same address, in this instance the 76 address.

Ive also tried modifying the server address for the account to be the ip address not the domain name (even though from the debug log its resolving to the correct address). This also fails to create the connection properly.

(08:29:58) account: Connecting to account ******
(08:29:58) connection: Connecting. gc = 02120BD0
(08:29:58) dnsquery: Performing DNS lookup for 76.13.15.34
(08:29:58) dnsquery: IP resolved for 76.13.15.34
(08:29:58) proxy: Attempting connection to 76.13.15.34
(08:29:58) proxy: Connecting to 76.13.15.34:5050 with no proxy
(08:29:58) proxy: Connection in progress
(08:29:58) proxy: Connecting to 76.13.15.34:5050.
(08:29:58) yahoo: 95 bytes to read, rxlen is 115
(08:29:58) yahoo: Yahoo Service: 0x57 Status: 1
(08:29:58) yahoo: yahoo status: 0

The connection between the two clients is setup the exact same way, port and host, but pidgin is unable to connect. This started occuring around 13:00EST on 6/18 for me and I have not be able to login to yahoo accounts from Pidgin since then.

comment:7 Changed 10 years ago by gagern

I had a mistake in my package list; the thirs package is sent by pidgin, not received. Tried to correct the tickedt description accordingly, but was rewarded with a HTTP 500 Internal Server Error message. A working server like 66.163.181.167 seems to respond to that third package with a service=0x55 message, while the problematic servers don't answer at all.

As the yahoo messenger for windows seems to have no problems connecting, I don't assume the servers are actually broken, only they don't behave the way pidgin expects them to. I'll try to get my hands on a piece of traffic from the windows client, see if I can spot a difference.

comment:8 Changed 10 years ago by gagern

  • Description modified (diff)

comment:9 Changed 10 years ago by gagern

OK, here is a dump of what Yahoo Messenger seems to be doing:

  1. send service=0x57 status=0
  2. recv service=0x57 status=1
  3. DNS lookup for login.yahoo.com
  4. HTTPS connection to login.yahoo.com, content encrypted
  5. send service=0x54 status=0x5a55aa55 (Wireshark calls this "Web Login")
  6. recv service=0x55 status=0

So the main difference seems to be the status of the 0x54 authentication response.

There is one occurrence in the pidgin code sending a packet with status YAHOO_STATUS_WEBLOGIN, but it uses service YAHOO_SERVICE_WEBLOGIN, not YAHOO_SERVICE_AUTHRESP, and it furthermore seems to be disabled using the TRY_WEBMESSENGER_LOGIN preprocessor switch. So maybe there is some code that could be worked on to get this going, I don't know.

comment:10 Changed 10 years ago by breaux

Is this explanation correct?

comment:11 Changed 10 years ago by pozunmv

@breaux that does seem like what could be happening, however looking at the communication going on when I connect with an older client doesn't make sense. The other client I am using which works on servers that pidgin doesn't and appears to use an even older version for the authentication method. According to the data that it sends its using version 12 of the YMSG protocol and connects without issue. When looking at the traffic pidgin creates it's using version 15 of the protocol. Now if it were a simple upgrade to the yahoo servers causing the issue, I would expect an even older version of the YMSG protocol to error out as well. If they did upgrade these servers to a non-backwards compatible protocol I would imagine that version 12 would also be broken, not that version 15 breaks where as version 12 still works. I could be wrong but it just doesn't make sense to me.

comment:12 Changed 10 years ago by deryni

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #8853.
Yes, Yahoo auth is changing. Yes, pidgin is being updated. The code for it exists and will be in pidgin 2.6.0. I'm marking this as a duplicate since it almost certainly is, if it isn't however speak up and this ticket will be reopened.

comment:13 Changed 10 years ago by deryni

  • Resolution duplicate deleted
  • Status changed from closed to new

Reopening for now to try to help prevent duplicates. #8853 didn't start out covering this issue but has morphed into covering it at this point but still also covers a different issue.

comment:14 Changed 10 years ago by deryni

Ticket #9418 has been marked as a duplicate of this ticket.

comment:15 Changed 10 years ago by deryni

Ticket #9416 has been marked as a duplicate of this ticket.

comment:16 Changed 10 years ago by deryni

Ticket #9421 has been marked as a duplicate of this ticket.

comment:17 Changed 10 years ago by deryni

Ticket #9419 has been marked as a duplicate of this ticket.

comment:18 Changed 10 years ago by deryni

Ticket #9413 has been marked as a duplicate of this ticket.

comment:19 Changed 10 years ago by backrowhacker

Having the same problem, totally know there's a fix coming. It looks like yahoo hasn't changed all their servers yet. Using cs101.msg.mud.yahoo.com or cs102.msg.mud.yahoo.com or scsc.msg.yahoo.com (ala this blog: http://webupd8.blogspot.com/2009/06/pidgin-256-yahoo-fix.html) seems to work for now. I only tried the first two on two different machines, but they both work fine for me.

comment:20 Changed 10 years ago by andrixnet

http://stuff.techwhack.com/6804-yahoo-messenger-pidgin

Read this article and the comments. Apparently Yahoo is (again) doing unfriendly changes to their servers.

comment:21 Changed 10 years ago by dj2u

I have the same problem from a few days, im using pidgin 2.5.5 (from mandriva 2009.1) the same problems exist with kopete.

surprisingly i can still log in to yahoo with pidgin from my xandros on eeepc900 but right after login it gives me a message there telling this version of YM will stop working after august.

i will boot into xandros and give mmore details soon.

below the debug output of 2.5.5 (with problem):

(13:46:14) prefs: /purple/savedstatus/default changed, scheduling save.
(13:46:14) account: Connecting to account XXXXXXXX
(13:46:14) connection: Connecting. gc = 0xa2343f0
(13:46:14) dns: DNS query for 'scs.msg.yahoo.com' queued
(13:46:14) dns: Wait for DNS child 17839 failed: Keine Kind-Prozesse
(13:46:14) dns: Created new DNS child 21634, there are now 1 children.
(13:46:14) dns: Successfully sent DNS request to child 21634
(13:46:14) dns: Got response for 'scs.msg.yahoo.com'
(13:46:14) dnsquery: IP resolved for scs.msg.yahoo.com
(13:46:14) proxy: Attempting connection to 68.180.217.11
(13:46:14) proxy: Connecting to scs.msg.yahoo.com:5050 with no proxy
(13:46:14) proxy: Connection in progress
(13:46:14) proxy: Connecting to scs.msg.yahoo.com:5050.
(13:46:14) yahoo: 91 bytes to read, rxlen is 111
(13:46:14) yahoo: Yahoo Service: 0x57 Status: 1
(13:46:14) yahoo: yahoo status: 0

comment:22 Changed 10 years ago by dj2u

ok now from xandros (pidgin 2.0.2):

(14:21:43) prefs: /purple/savedstatus/default changed, scheduling save.
(14:21:43) account: Connecting to account XXXXX
(14:21:43) connection: Connecting. gc = 0x84954b8
(14:21:43) dns: DNS query for 'scs.msg.yahoo.com' queued
(14:21:43) dns: Created new DNS child 2587, there are now 1 children.
(14:21:43) dns: Successfully sent DNS request to child 2587
(14:21:43) dns: Got response for 'scs.msg.yahoo.com'
(14:21:43) dnsquery: IP resolved for scs.msg.yahoo.com
(14:21:43) proxy: Attempting connection to 68.180.217.9
(14:21:43) proxy: Connecting to scs.msg.yahoo.com:5050 with no proxy
(14:21:43) proxy: Connection in progress
(14:21:43) proxy: Connected to scs.msg.yahoo.com:5050.
(14:21:43) yahoo: 101 bytes to read, rxlen is 121
(14:21:43) yahoo: Yahoo Service: 0x57 Status: 1
(14:21:43) yahoo: yahoo status: 0
(14:21:44) yahoo: 216 bytes to read, rxlen is 236
(14:21:44) yahoo: Yahoo Service: 0x14 Status: 1
(14:21:44) yahoo: 496 bytes to read, rxlen is 1024
(14:21:44) yahoo: Yahoo Service: 0x55 Status: 5
(14:21:44) yahoo: 972 bytes to read, rxlen is 508
(14:21:44) yahoo: 972 bytes to read, rxlen is 1532
(14:21:44) yahoo: Yahoo Service: 0x55 Status: 5
(14:21:44) yahoo: 976 bytes to read, rxlen is 540
(14:21:44) yahoo: 976 bytes to read, rxlen is 1564
(14:21:44) yahoo: Yahoo Service: 0x55 Status: 5
(14:21:44) yahoo: 976 bytes to read, rxlen is 568
(14:21:44) yahoo: 976 bytes to read, rxlen is 1592
(14:21:44) yahoo: Yahoo Service: 0x55 Status: 5
(14:21:44) yahoo: 161 bytes to read, rxlen is 596
(14:21:44) yahoo: Yahoo Service: 0x55 Status: 5
(14:21:44) yahoo: 893 bytes to read, rxlen is 415
(14:21:44) yahoo: 893 bytes to read, rxlen is 639
(14:21:44) yahoo: 893 bytes to read, rxlen is 1663
(14:21:44) yahoo: Yahoo Service: 0x55 Status: 0

after that loads of buddy updates and so on... and a pop up message stating:

Warning: This version of Messenger will expire on August 15,
2009. Please upgrade to the latest supported version: http://
messenger.yahoo.com/download .

comment:23 Changed 10 years ago by dj2u

ok once again me...

i changed the pager server to the IP suggested by richard and this fixed both, pidgin and kopete...

comment:24 Changed 10 years ago by rekkanoryo

Ticket #9423 has been marked as a duplicate of this ticket.

comment:25 Changed 10 years ago by rekkanoryo

Ticket #9424 has been marked as a duplicate of this ticket.

comment:26 Changed 10 years ago by rekkanoryo

Ticket #9425 has been marked as a duplicate of this ticket.

comment:27 Changed 10 years ago by rekkanoryo

Ticket #9428 has been marked as a duplicate of this ticket.

comment:28 Changed 10 years ago by rekkanoryo

Ticket #9429 has been marked as a duplicate of this ticket.

comment:29 Changed 10 years ago by rekkanoryo

Ticket #9427 has been marked as a duplicate of this ticket.

comment:30 in reply to: ↑ 3 Changed 10 years ago by kaustubhvp

Replying to SlumberJack:

Changing the Page Server from scs.msg.yahoo.com to 66.163.181.167 has resolved the issue for me.

works for me too.

comment:31 Changed 10 years ago by rekkanoryo

Ticket #9459 has been marked as a duplicate of this ticket.

comment:32 Changed 10 years ago by deryni

Ticket #9464 has been marked as a duplicate of this ticket.

comment:33 Changed 10 years ago by deryni

Ticket #9465 has been marked as a duplicate of this ticket.

comment:34 Changed 10 years ago by darkrain42

Ticket #9468 has been marked as a duplicate of this ticket.

comment:35 follow-up: Changed 10 years ago by deryni

  • Milestone set to 2.5.7
  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed with the release of pidgin 2.5.7.

comment:36 Changed 10 years ago by dj2u

thanks!

checked it on mdv 2009.1 2.5.7 fixed the prob :-)

comment:37 in reply to: ↑ 35 Changed 10 years ago by bwsmith7

Replying to deryni:

This should be fixed with the release of pidgin 2.5.7.

Just downloaded 2.5.7, Yahoo still refused to connect. I saw that my server was still set at 66.163.181.172; when I changed it back to the original (scs.msg.yahoo.com), Yahoo connected quickly.

Changed 10 years ago by avatar666

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!