Opened 10 years ago

Closed 10 years ago

#9416 closed defect (duplicate)

Yahoo Protocol Change

Reported by: BobDaFish Owned by: marv
Milestone: Component: Yahoo!/Yahoo! JAPAN
Version: 2.5.6 Keywords:
Cc: dlevine278

Description

Yahoo rolled out new authentication method.

http://developer.yahoo.net/blog/archives/2009/06/oauth_update_ux.html

Fixes suggested here don't work any longer:

http://www.celticwolf.com/useful-information/faqs/26-pidgin-yahoo

Error looks like this regardless of server tried:

(08:15:32) account: Connecting to account xxxxxxxxxx (08:15:32) connection: Connecting. gc = 0266ACA0 (08:15:32) dnsquery: Performing DNS lookup for 76.13.15.35 (08:15:32) dnsquery: IP resolved for 76.13.15.35 (08:15:32) proxy: Attempting connection to 76.13.15.35 (08:15:32) proxy: Connecting to 76.13.15.35:5050 with no proxy (08:15:32) proxy: Connection in progress (08:15:32) proxy: Connecting to 76.13.15.35:5050. (08:15:32) yahoo: 100 bytes to read, rxlen is 120 (08:15:32) yahoo: Yahoo Service: 0x57 Status: 1 (08:15:32) yahoo: yahoo status: 99

Change History (2)

comment:1 Changed 10 years ago by dlevine278

Folks,

According to a reliable source (and I apologize for not having the details) is that Y! is no longer sending back a presence packet upon authentication. I'm sure that a review of a Wireshark capture will confirm this.

Hope this helps.

Dave

comment:2 Changed 10 years ago by deryni

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #9414.
Also #8853.

People in #pidgin have been having success with the help from that link still, we know about the auth change, pidgin 2.6.0 will have the new auth code.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!