Opened 10 years ago

Closed 10 years ago

#9535 closed defect (fixed)

Pidgin 2.5.7 Crash, libgobject-2.0-0.dll

Reported by: AdamS Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.5.7 Keywords:
Cc:

Description (last modified by AdamS)

Windows Xp Pro SP3

When run pidgin will encounter and error and close shortly after the buddy window appears.

pidgin.log & pidgin.rpt attached.

Windows Event log error.

Event Type: Error Event Source: Application Error Event Category: None Event ID: 1000 Date: 6/25/2009 Time: 9:01:25 AM User: N/A Computer: PCName Description: Faulting application pidgin.exe, version 2.5.7.0, faulting module libgobject-2.0-0.dll, version 2.18.4.0, fault address 0x000076e0.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 41 70 70 6c 69 63 61 74 Applicat 0008: 69 6f 6e 20 46 61 69 6c ion Fail 0010: 75 72 65 20 20 70 69 64 ure pid 0018: 67 69 6e 2e 65 78 65 20 gin.exe 0020: 32 2e 35 2e 37 2e 30 20 2.5.7.0 0028: 69 6e 20 6c 69 62 67 6f in libgo 0030: 62 6a 65 63 74 2d 32 2e bject-2. 0038: 30 2d 30 2e 64 6c 6c 20 0-0.dll 0040: 32 2e 31 38 2e 34 2e 30 2.18.4.0 0048: 20 61 74 20 6f 66 66 73 at offs 0050: 65 74 20 30 30 30 30 37 et 00007 0058: 36 65 30 0d 0a 6e0..

Attachments (2)

pidgin.RPT (2.5 KB) - added by AdamS 10 years ago.
debug.log (13.2 KB) - added by AdamS 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by AdamS

Changed 10 years ago by AdamS

comment:1 Changed 10 years ago by AdamS

  • Description modified (diff)

comment:2 Changed 10 years ago by AdamS

  • Description modified (diff)

comment:3 follow-up: Changed 10 years ago by darkrain42

  • Component changed from XMPP to winpidgin (gtk)
  • Owner changed from deryni to datallah

This looks to me like a crash in GTK+

comment:4 in reply to: ↑ 3 Changed 10 years ago by AdamS

Replying to darkrain42:

This looks to me like a crash in GTK+

So far I've tried uninstalling pidgin 2.5.5 and reinstalling 2.5.7. That DLL causes a crash with both versions. GTK+ was uninstalled each time as well.

Next will be to try installing a newer version of GTK+ to see if that resolves the issue.

comment:5 Changed 10 years ago by bernmeister

AdamS: Any luck with the GTK reinstall?

comment:6 Changed 10 years ago by darkrain42

  • Status changed from new to pending

comment:7 Changed 10 years ago by AdamS

  • Status changed from pending to new

Sorry for the delayed update.

This issue was resolved by deleting the accounts.xml file located in the "C:\Documents and Settings\[User Name]\Application Data\.purple" folder

I'm still unsure of the root cause of this crash, but it seemed to happen when pidginw as attempting to load the users contact list.

comment:8 Changed 10 years ago by AdamS

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!