Opened 7 years ago

Last modified 7 years ago

#9606 new defect

Cannot log into hotmail account: pidgin times out.

Reported by: rgladwell Owned by: khc
Milestone: Component: MSN
Version: 2.5.7 Keywords:
Cc:

Description

Attempts to log into my hotmail account fails on both Windows and Linux (Fedora 10/11), using the 2.5.7 release. See attached debug log.

This only seems to happen for my older, main account, if I use another, newer account this works fine. I can log into and use my older main MSN account using other clients, such as Empathy and Meebo.

Attachments (2)

pidgin.msn.log (223.6 KB) - added by rgladwell 7 years ago.
Debug log of my pidgin session.
pidgin.log (212.9 KB) - added by rgladwell 7 years ago.
Log file for pidgin 2.6.1 on Fedora Linux 11

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by rgladwell

Debug log of my pidgin session.

comment:1 Changed 7 years ago by QuLogic

  • Status changed from new to pending

The server is complaining about the buddy nor'morgwae@... in the Buddies group. I think this is a typo since there's another entry without the apostrophe.

I believe the buddies should still be shown in the buddy list even though Pidgin doesn't completely think you have logged in. If you remove this buddy (probably need to turn on Show Offline), you should be able to log in.

comment:2 Changed 7 years ago by rgladwell

  • Status changed from pending to new

Thanks for the feedback: I couldn't delete my nor'morgwae@… buddy through the Pidgin interface because the MSN account login never gets far enough to display this user in my offline buddy list.

Instead, I logged into mail.live.com and deleted my MSN contact through their contacts web. But nor'morgwae@... stills appears in the membership list downloaded from MSN. Pidgin sees this user and adds him to the block list, but for some reason won't complete login to my MSN account.

Meebo and other IM clients such as Empathy seem to handle this fine. Any advice as to what maybe causing this would be fantastic.

comment:3 Changed 7 years ago by rgladwell

I also deleted the user directly from the list of contacts in the blist.xml file in my $HOME/.purple directory.

comment:4 Changed 7 years ago by QuLogic

Can you try with 2.5.8?

I can't reproduce with the current code. We send a correct request and the server responds telling us the buddy doesn't exist, and we ignore it afterwards. If 2.5.8 doesn't work, then you can try again when 2.6.0 is released.

comment:5 Changed 7 years ago by bernmeister

Set to Pending...?

comment:6 Changed 7 years ago by rgladwell

I can confirm the issue is still extant with 2.5.8, will retry with 2.6.0 when it becomes available and update this issue with my findings.

comment:7 Changed 7 years ago by rgladwell

I can confirm this is still an issue for 2.6.0 and 2.6.1.

comment:8 Changed 7 years ago by QuLogic

  • Status changed from new to pending

Can you export the PURPLE_VERBOSE_DEBUG environment variable and then get a new debug log?

comment:9 Changed 7 years ago by rgladwell

  • Status changed from pending to new

Please find updated log file attached for pidgin 2.6.1.

Changed 7 years ago by rgladwell

Log file for pidgin 2.6.1 on Fedora Linux 11

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!