Opened 8 years ago

Closed 8 years ago

#9793 closed defect (duplicate)

In log viewer buddy's message in Hebrew appear as squares

Reported by: asteiner Owned by: datallah
Milestone: Component: winpidgin (gtk)
Version: 2.5.8 Keywords: log garbled
Cc:

Description (last modified by asteiner)

When I read previous converstaions with a buddy, whether in the log viewer or a conversation window, if the text is in Hebrew, all of the buddy's message appears as squares.

In contrast, my own messages look fine.

This doesn't happen with any user, but only specific ones. I'm guessing it has something to do with the font family.

The log files themselves seem OK - I can easily open and read them in my browser.

I'm using 2.5.8, but this started in a previous 2.5.x version (can't remember which one).

I'm using Windows XP SP3; The OS UI Language is English; The default language for non-Unicode software is Hebrew; The location is Japan; The locale (dates, currency, etc.) is Japanese.

I'm attaching a screenshot and a sample log. I modified them a bit to keep my buddy's privacy.

Attachments (2)

squares_instead_of_Hebrwe_letters_screenshots.PNG (37.0 KB) - added by asteiner 8 years ago.
2009-07-12.174742_0900JST.html (2.9 KB) - added by asteiner 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by asteiner

comment:1 Changed 8 years ago by asteiner

  • Description modified (diff)

comment:2 Changed 8 years ago by darkrain42

  • Component changed from MSN to winpidgin (gtk)
  • Owner changed from khc to datallah

Hmm, I bet Segoe UI doesn't have Hebrew glyphs. Datallah might know better about that (and how to change the font used to write the log?)

comment:3 Changed 8 years ago by datallah

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #604.
This is certainly a font problem - #604 (despite the title) covers this subject pretty thoroughly.

Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!