Opened 10 years ago

Closed 5 years ago

Last modified 3 years ago

#9891 closed defect (out of date)

Crash when pasting text with wiki link

Reported by: Firewave Owned by: jeff
Milestone: Component: MySpace
Version: 2.5.8 Keywords:
Cc:

Description

I was pasting the line "Niemi was first choice for the Finnish national team for almost a decade" from http://en.wikipedia.org/wiki/Antti_Niemi_(footballer) into a MySpaceIM chat and it crashed (reproducible) with the following backtrace:

Program received signal SIGSEGV, Segmentation fault.
0x77bd85f0 in strcmp () from C:\WINDOWS\syswow64\msvcrt.dll
(gdb) bt full
#0  0x77bd85f0 in strcmp () from C:\WINDOWS\syswow64\msvcrt.dll
No symbol table info available.
#1  0x68605618 in g_str_equal ()
   from C:\Program Files (x86)\Common Files\GTK\2.0\bin\libglib-2.0-0.dll
No symbol table info available.
#2  0x62489666 in html_tag_to_msim_markup (session=0x3cacd38, root=0x3fada78,
    begin=0x22e354, end=0x22e358) at markup.c:484
        href = (
    const gchar *) 0x3fadba0 "/wiki/Finland_national_football_team"
        link_text = (gchar *) 0x0
        ret = 0
        root = (xmlnode *) 0x3fada78
        begin = (gchar **) 0x22e354
        end = (gchar **) 0x22e358
#3  0x62489abf in msim_convert_xmlnode (session=0x3cacd38, out=0x3f65550,
    root=0x3fada78, f=0x62489430 <html_tag_to_msim_markup>, nodes_processed=0)
    at markup.c:593
        node = (xmlnode *) 0x22e354
        begin = (gchar *) 0x0
        end = (gchar *) 0x0
        tmp = (gchar *) 0x3fada78 "≡┘·\003"
        descended = 2286424
        root = (xmlnode *) 0x3fada78
#4  0x62489adf in msim_convert_xmlnode (session=0x3cacd38, out=0x3f65550,
    root=0x3fad968, f=0x62489430 <html_tag_to_msim_markup>, nodes_processed=0)
    at markup.c:607
        node = (xmlnode *) 0x3fada78
        begin = (gchar *) 0x3fadfe0 "á\001?"
        end = (gchar *) 0x3f953a0 "</f>"
        tmp = (gchar *) 0x3fad968 "░┘·\003"
        descended = 0
        root = (xmlnode *) 0x3fad968
#5  0x62489adf in msim_convert_xmlnode (session=0x3cacd38, out=0x3f65550,
    root=0x3faa4a8, f=0x62489430 <html_tag_to_msim_markup>, nodes_processed=0)
    at markup.c:607
        node = (xmlnode *) 0x3fad968
        begin = (gchar *) 0x3f4ed88 "└\001?"
        end = (gchar *) 0x3faa3e8 "</c></f>"
        tmp = (gchar *) 0x3faa4a8 "╨φ⌠\003"
        descended = 0
        root = (xmlnode *) 0x3faa4a8
#6  0x62489adf in msim_convert_xmlnode (session=0x3cacd38, out=0x3f65550,
    root=0x3ebb068, f=0x62489430 <html_tag_to_msim_markup>, nodes_processed=0)
    at markup.c:607
        node = (xmlnode *) 0x3faa4a8
        begin = (gchar *) 0x3faa3e8 "</c></f>"
        end = (gchar *) 0x3c8ba78 ""
        tmp = (gchar *) 0x3ebb068 "\030■╨\003"
        descended = 0
        root = (xmlnode *) 0x3ebb068
#7  0x62489bca in msim_convert_xml (session=0x3cacd38, raw=0x0,
    f=0x62489430 <html_tag_to_msim_markup>) at markup.c:664
        root = (xmlnode *) 0x3ebb068
        str = (GString *) 0x3f65550
        enclosed_raw = (gchar *) 0x3f65550 "\210┴·\003]"
        __PRETTY_FUNCTION__ = "msim_convert_xml"
        f = (MSIM_XMLNODE_CONVERT) 0x62489430 <html_tag_to_msim_markup>
#8  0x62489cad in html_to_msim_markup (session=0x3cacd38,
    raw=0x3fac028 "<font color=\"#000000\"><font face=\"sans-serif\"><font size=
\"3\">Niemi was first choice for the </font></font><font size=\"3\"><a href=\"/
wiki/Finland_national_football_team\"><font face=\"'Times New Roman'\">"...)
    at markup.c:730
        markup = (gchar *) 0x3ebb068 "\030■╨\003"
        session = (MsimSession *) 0x3f65550
        raw = (const gchar *) 0x0
#9  0x62482fec in msim_send_im (gc=0x3caccc0,
    who=0x3be8e18 "gazzafromanorakcity",
    message=0x3fac028 "<font color=\"#000000\"><font face=\"sans-serif\"><font s
ize=\"3\">Niemi was first choice for the </font></font><font size=\"3\"><a href
=\"/wiki/Finland_national_football_team\"><font face=\"'Times New Roman'\">"...,
 flags=PURPLE_MESSAGE_SEND) at myspace.c:2279
        session = (MsimSession *) 0x3cacd38
        message_msim = (gchar *) 0x23d69e8 "Xj=\002"
        rc = 63622456
        __PRETTY_FUNCTION__ = "msim_send_im"
        gc = (PurpleConnection *) 0x0
        who = (const gchar *) 0x3be8e18 "gazzafromanorakcity"
        message = (const gchar *) 0x0
#10 0x67cfcfce in serv_send_im (gc=0x3caccc0,
    name=0x3be8e18 "gazzafromanorakcity",
    message=0x3fac028 "<font color=\"#000000\"><font face=\"sans-serif\"><font s
ize=\"3\">Niemi was first choice for the </font></font><font size=\"3\"><a href
=\"/wiki/Finland_national_football_team\"><font face=\"'Times New Roman'\">"...,
 flags=PURPLE_MESSAGE_SEND) at server.c:146
        conv = (PurpleConversation *) 0x3e6d460
        account = (PurpleAccount *) 0x23d69e8
        presence = (PurplePresence *) 0x23d7180
        prpl = (PurplePlugin *) 0x0
        prpl_info = (PurplePluginProtocolInfo *) 0x3cacd38
        val = -22
        auto_reply_pref = (const gchar *) 0x23d69e8 "Xj=\002"
        __PRETTY_FUNCTION__ = "serv_send_im"
        message = 0x0
        flags = 0
#11 0x67cd9e19 in common_send (conv=0x3be8e18, message=0x23d69e8 "Xj=\002",
    msgflags=0) at conversation.c:136
        im = (PurpleConvIm *) 0x3e6dcf0
        type = PURPLE_CONV_TYPE_IM
        account = (PurpleAccount *) 0x23d69e8
        gc = (PurpleConnection *) 0x3caccc0
        displayed = 0x3fabe10 "<font color=\"#000000\"><font face=\"sans-serif\"
><font size=\"3\">Niemi was first choice for the </font></font><font size=\"3\"
><a href=\"/wiki/Finland_national_football_team\"><font face=\"'Times New Roman'
\">"...
        sent = 0x3fac028 "<font color=\"#000000\"><font face=\"sans-serif\"><fon
t size=\"3\">Niemi was first choice for the </font></font><font size=\"3\"><a h
ref=\"/wiki/Finland_national_football_team\"><font face=\"'Times New Roman'\">".
..
        err = 66474192
        __PRETTY_FUNCTION__ = "common_send"
        msgflags = 63622456
#12 0x64a6493d in send_cb (widget=0x3e45000, gtkconv=0x3e64d08)
    at gtkconv.c:589
        conv = (PurpleConversation *) 0x3e6d460
        account = (PurpleAccount *) 0x23d69e8
        gc = (PurpleConnection *) 0x0
        flags = 0
        buf = 0x3ca4c88 "<font color=\"#000000\"><font face=\"sans-serif\"><font
 size=\"3\">Niemi was first choice for the </font></font><font size=\"3\"><a hr
ef=\"/wiki/Finland_national_football_team\"><font face=\"'Times New Roman'\">"..
.
        clean = 0x3be8e18 "gazzafromanorakcity"
#13 0x63a43955 in g_closure_invoke ()
   from C:\Program Files (x86)\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll
No symbol table info available.
#14 0x63a58275 in signal_emit_unlocked_R ()
   from C:\Program Files (x86)\Common Files\GTK\2.0\bin\libgobject-2.0-0.dll
No symbol table info available.
#15 0x0022e870 in ?? ()
No symbol table info available.
#16 0x00000001 in ?? ()
No symbol table info available.
#17 0x03cf31f0 in ?? ()
No symbol table info available.
#18 0x0022e748 in ?? ()
No symbol table info available.
#19 0x00000000 in ?? ()
No symbol table info available.

Change History (8)

comment:1 Changed 10 years ago by Firewave

  • Summary changed from Crash when pasting text with wiki link into to Crash when pasting text with wiki link

comment:2 Changed 10 years ago by Firewave

The browser I was pasting it from was Google Chrome 3.0.197.11 on Windows XP x64.

comment:3 Changed 10 years ago by Firewave

  • Component changed from unclassified to MySpace
  • Owner changed from rekkanoryo to jeff

comment:4 Changed 10 years ago by Jaywalker

Ok, from what I can gather, Chrome has a different way of processing web pages, so the text you copy includes some strange markup which is causing msim to think that the whole string is an html link. What is your sytem/chrome/pidgin locale settings? and is there any way you can paste exactly (formatting and all) what you're trying to paste in Pidgin into here?

comment:5 Changed 10 years ago by Firewave

I assume the locale is default/english in all cases as I am running an english system and usually choose the default/english language.

So far I have not been successful getting the pasted string with formating.

On a side note. The URL in the initial report is not being parsed correctly. It misses the closing ")".

comment:6 Changed 10 years ago by jeff

  • Milestone set to Patches welcome

comment:7 Changed 5 years ago by MarkDoliner

  • Resolution set to out of date
  • Status changed from new to closed

The MySpace? IM protocol plugin has been removed from Pidgin for 3.0.0 because the IM network no longer exists.

comment:8 Changed 3 years ago by Robby

  • Milestone Patches welcome deleted
Note: See TracTickets for help on using tickets.
All information, including names and email addresses, entered onto this website or sent to mailing lists affiliated with this website will be public. Do not post confidential information, especially passwords!